Time Zone

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤9).

 

 

Output

For each test, output the time in the format of hh:mm (24-hour clock).

 

 

Sample Input

 

3

11 11 UTC+8

11 12 UTC+9

11 23 UTC+0

 

 

Sample Output

 

11:11

12:12

03:23

 

题目分析:对于字符串的处理字符后的数字可以用sscanf来处理。这样就成了简单的数学问题。还有就是注意小数的处理

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    int n,h,m;
    double s;
    char fu[20];
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d %d ",&h,&m);
        scanf("%s",fu);
        sscanf(fu+4,"%lf",&s);
        int newh,newm;
        newh=s/1.0;
        if(fu[3]=='+')
        {
            h+=(newh-8);
            newm=(s-newh)*60+0.01;
            m+=newm;
        }
        else
        {
            h=h-newh-8;
            newm=(s-newh)*60+0.01;
            m-=newm;
        }
         if(m>=60)
            {
                m-=60;
                h++;
            }
        if(h>=24)
            {
                h-=24;
            }
        if(m<0)
            {
                m+=60;
                h--;
            }
        if(h<0)
            {
                h+=24;
            }
        printf("%02d:%02d\n",h,m);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值