UVa 725 Division(枚举)

                                                UVA 725 Division


Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits0 through9 once each, such that the first number divided by the second is equal to an integerN, where$2\le N \le 79$. That is,


abcde / fghij =N

where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input 

Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

Output 

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).

Your output should be in the following general form:


xxxxx / xxxxx =N

xxxxx / xxxxx =N

.

.


In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions forN.". Separate the output for two different values ofN by a blank line.

Sample Input 

61
62
0

Sample Output 

There are no solutions for 61.

79546 / 01283 = 62
94736 / 01528 = 62

#include <stdio.h>
#include <string.h>
using namespace std;

int n, a[10];

int judge(int x, int y) {
	int tx = x, ty = y;
	memset(a, 0, sizeof(a));
	while (tx) {
		if (a[tx % 10])
			return 0;
		else
			a[tx % 10] = 1;
		tx /= 10;
	}
	while (ty) {
		if (a[ty % 10])
			return 0;
		else
			a[ty % 10] = 1;
		ty /= 10;
	}
	for (int i = 1; i <= 9; i++)
		if (!a[i])
			return 0;
	printf("%05d / %05d = %d\n", x, y, n);
	return 1;
}

int main() {
	int index = 0, flag = 0;
	while (scanf("%d", &n) == 1) {
		if (n == 0)
			break;
		if (index > 1)
			printf("\n");
		for (int i = 12345; i <= 98765; i++) {
			if (i % n == 0) 
				if (judge(i, i / n)) 
					flag = 1;
		}
		if (!flag)
			printf("There are no solution for %d.\n", n);
		flag = 0;
		if (!index)
			printf("\n");
		index++;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值