UVa 10976 分数拆分

It is easy to see that for every fraction in the form 1 k (k > 0), we can always find two positive integers x and y, x ≥ y, such that: 1 k = 1 x + 1 y Now our question is: can you write a program that counts how many such pairs of x and y there are for any given k? Input Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000). Output For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of x and y, as shown in the sample output.

Sample Input

2

12

Sample Output

2

1/2 = 1/6 + 1/3

1/2 = 1/4 + 1/4

8

1/12 = 1/156 + 1/13

1/12 = 1/84 + 1/14

1/12 = 1/60 + 1/15

1/12 = 1/48 + 1/16

1/12 = 1/36 + 1/18

1/12 = 1/30 + 1/20

1/12 = 1/28 + 1/21

1/12 = 1/24 + 1/24


枚举对象为x,y . 由于 x ≥ y,所以 1/x ≤ 1/y ,所以 1/k - 1/y ≤ 1/y,即 y 小于等于 2k

#include <stdio.h>

int main() {
	int k, x[10010], y[10010];
	while (scanf("%d", &k) == 1) {
		int cnt = 0;
		for (int i = k + 1; i <= 2 * k; i++) {
			if (!((i * k) % (i - k))) {
				x[++cnt] = (i * k) / (i - k);
				y[cnt] = i;
			}
		}
		printf("%d\n", cnt);
		for (int i = 1; i <= cnt ; i++)
			printf("1/%d = 1/%d + 1/%d\n", k, x[i], y[i]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值