UVa 10361 Automatic Poetry

\Oh God", Lara Croft exclaims, \it's one of these dumb riddles again!"
In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, pre-
historic caves and medival hallways. Now she is standing in front of some important Germanic looking
doorway and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually
challenging.
This time, the riddle involves poems containing a \Schuttelreim". An example of a Schuttelreim is
the following short poem:
Ein Kind halt seinen Schnabel nur,
wenn es hangt an der Nabelschnur.
Note:
German users, please, forgive me. I had to modify something as they were not appearing
correctly in plain text format
A Schuttelreim seems to be a typical German invention. The funny thing about this strange type
of poetry is that if somebody gives you the rst line and the beginning of the second one, you can
complete the poem yourself. Well, even a computer can do that, and your task is to write a program
which completes them automatically. This will help Lara concentrate on the \action" part of Tomb
Raider and not on the \intellectual" part.
Input
The input will begin with a line containing a single number
n
. After this line follow
n
pairs of lines
containing Schuttelreims. The rst line of each pair will be of the form
s
1
<
s
2
>
s
3
<
s
4
>
s
5
where the
s
i
are possibly empty, strings of lowercase characters or blanks. The second line will be
a string of lowercase characters or blanks ending with three dots `
...
'. Lines will we at most 100
characters long.
Output
For each pair of Schuttelreim lines
l
1
and
l
2
you are to output two lines
c
1
and
c
2
in the following way:
c
1
is the same as
l
1
only that the bracket marks `
<
' and `
>
' are removed. Line
c
2
is the same as
l
2
,
except that instead of the three dots the string
s
4
s
3
s
2
s
5
should appear.
SampleInput
3
ein kind haelt seinen <schn>abel <n>ur
wenn es haengt an der ...
weil wir zu spaet zur <>oma <k>amen
verpassten wir das ...
<d>u <b>ist
...
SampleOutput
ein kind haelt seinen schnabel nur
wenn es haengt an der nabel schnur
weil wir zu spaet zur oma kamen
verpassten wir das koma amen
du bist
bu dist
#include <stdio.h>
#include <string.h>
#define N 110
char str1[N], str2[N], s[10][N];

int main() {
	int n, t, len, p;
	scanf("%d\n", &n);
	while (n--) {
		memset(str1, 0, sizeof(str1));
		memset(str2, 0, sizeof(str1));
		fgets(str1, N, stdin);
		fgets(str2, N, stdin);
		len = strlen(str1);
		p = 0, t = 1;
		for (int j = 0; j < len; j++) {
			if (str1[j] == '<' || str1[j] == '>') {
				s[t][p] = '\0';
				t++;
				p = 0;
			}
			else {
				printf("%c", str1[j]);
				s[t][p++] = str1[j];
			}
		}
		s[t][p] = '\0';
		int j = 0;
		while (str2[j] != '.')
			printf("%c", str2[j++]);
		printf("%s", s[4]);
		printf("%s", s[3]);
		printf("%s", s[2]);
		printf("%s", s[5]);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值