POJ Ultra-QuickSort 逆序数 树状数组 归并排序

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 51719 Accepted: 18979

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source


求逆序数的模板题,求逆序数可用树状数组,归并排序,线段树求解,本文给出 树状数组,归并排序的解法。

归并排序:
#include<cstdio>
#include<iostream>
using namespace std;
#define max 500002
int arr[max],b[max];//b[]为临时序列,arr[]为待排序数列,结果在arr[]中
int tp[max];
long long cnt=0;//总逆序数
void Merge(int a[],int start,int mid,int end){
	int i =start,j=mid+1,k=start;
	while(i<=mid&&j<=end){
		if(a[i]<=a[j]){
            cnt+=j-mid-1;
			b[k++]=a[i++];
		}else{
		    cnt+=j-k;
			b[k++]=a[j++];
		}
	}
	while(i<=mid){
        cnt+=end-mid;
		b[k++]=a[i++];
	}
	while(j<=end){
		b[k++]=a[j++];
	}
	for(int i=start;i<=end;i++){
        a[i]=b[i];
    }
}
void MergeSort(int a[], int start,int end){
	if(start<end){
		int mid=(start+end)/2;
		MergeSort(a,start,mid);
		MergeSort(a,mid+1,end);
		Merge(a,start,mid,end);
	}
}
int main(){
    int n;
    while(~scanf("%d",&n)&&n){
        for(int i=0;i<n;i++){
            scanf("%d",&arr[i]);
        }
        cnt=0;
        MergeSort(arr,0,n-1);
        printf("%I64d\n",cnt/2);
    }
    return 0;
}

树状数组:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define lowbit(x) (x&(-x))
using namespace std;
const int MAX = 500005;
struct data{
    int id,val;
}num[MAX];
int n, C[MAX];
bool cmp(data a, data b){
    return a.val>b.val;
}
void add(int i){
    while(i<=n){
        C[i]+=1;
        i+=lowbit(i);
    }
}
long long sum(int i){
    long long ans = 0;
    while(i>0){
        ans+=C[i];
        i-=lowbit(i);
    }
    return ans;
}

int main(){
    while(scanf("%d",&n)&&n){
        memset(C,0,sizeof(C));
        for(int i=0;i<n;i++){
            num[i].id=i+1;
            scanf("%d",&num[i].val);
        }
        sort(num,num+n,cmp);//离散化,将数组按降序排序,再求下标的逆序数,下标的逆序数与值逆序数相等
        long long ans = 0;
        for(int i=0;i<n;i++){
            ans+=sum(num[i].id-1);//求在i前面比第i个数大的数的个数
            add(num[i].id);
        }
        printf("%I64d\n", ans);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值