1190: 零起点学算法97——A == B ?(Java)

80 篇文章 18 订阅
32 篇文章 0 订阅

WUSTOJ 1190: 零起点学算法97——A == B ?

Description

        Give you two integer numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

Input

        each test case contains two integer numbers A and B.

Output

        for each case, if A is equal to B, you should print “YES”, or print “NO”.

Sample Input
1 2
2 2
3 3
4 3
Sample Output
NO
YES
YES
NO
HINT

        注意A、B数位最多100位。

代码
/**
 * 用时:472ms
 * @author wowpH
 * @version A1.1
 * @date 2019年4月13日 下午9:35:04
 */

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	private Scanner sc;
	private BigInteger A, B;

	public Main() {
		sc = new Scanner(System.in);
		while(sc.hasNext()) {
			A = sc.nextBigInteger();
			B = sc.nextBigInteger();
			if(A.equals(B)) {
				System.out.println("YES");
			} else {
				System.out.println("NO");
			}
		}
		sc.close();
	}

	public static void main(String[] args) {
		new Main();
	}

}

        我为什么没有早点发现这个大数类(BigInteger),这么好用的一个类。
        虽然上面代码是正确的的,但是我想知道为什么下面这个就不行呢?

double 的表示范围是:1.7976931348623157e+308 这个为什么不行呢?

/**
 * 提交:Wrong Answer
 * @author wowpH
 * @version A1.0
 * @date 2019年4月13日 下午9:35:04
 */

import java.util.Scanner;

public class Main {

	private Scanner sc;
	private double A, B;

	public Main() {
		sc = new Scanner(System.in);
		while(sc.hasNext()) {
			A = sc.nextDouble();
			B = sc.nextDouble();
			if(A == B) {
				System.out.println("YES");
			} else {
				System.out.println("NO");
			}
		}
		sc.close();
	}

	public static void main(String[] args) {
		new Main();
	}

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值