LightOj 1214 Large Division(大数除法)

Large Division

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

解题思路:

模拟除法运算即可。

AC代码:

#include <bits/stdc++.h>
using namespace std;

typedef long long ll;

int main(){
    int T,t = 1;
    scanf("%d",&T);
    while(T--){
        char num[300];
        ll div;
        scanf("%s%lld",num,&div);
        printf("Case %d: ",t++);
        if(div == 0){
            printf("not divisible\n");
            continue;
        }
        div = div>=0?div:-div;
        if(num[0] == '-')
            num[0] = '0';
        int len = strlen(num);
        ll ans = 0;
        for(int i = 0; i < len; i++)
            ans = ((num[i]-'0')+ans*10) % div;
        if(ans == 0)
            printf("divisible\n");
        else
            printf("not divisible\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值