FZU 2140 Forever 0.5(构造)

Forever 0.5

Description

Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

1. The distance between any two points is no greater than 1.0.

2. The distance between any point and the origin (0,0) is no greater than 1.0.

3. There are exactly N pairs of the points that their distance is exactly 1.0.

4. The area of the convex hull constituted by these N points is no less than 0.5.

5. The area of the convex hull constituted by these N points is no greater than 0.75.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100

Output

For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.

Sample Input

3235

Sample Output

NoNoYes0.000000 0.525731-0.500000 0.162460-0.309017 -0.4253250.309017 -0.4253250.500000 0.162460

Hint

This problem is special judge.


解题思路:

有n个点,要求:

1.任意两点的距离≤ 1.0

2.每个点与原点的距离≤1.0

3.有N对点间的距离=1.0

4.N个点形成的面积≥0.5且≤0.75

可以先取一个以原点为顶点,另外两个点在单位圆上的正三角形


其他的点就在圆弧BC上,将BC等分即可。

由于只有三个点时,并不符合面积要求。因此至少需要四个点。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

const double pi = acos(-1.0);

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        if(n < 4)
            puts("No");
        else{
            puts("Yes");
            printf("%.6lf %.6lf\n",0.0,0.0);
            printf("%.6lf %.6lf\n",1.0,0.0);
            printf("%.6lf %.6lf\n",0.5,sqrt(3.0)/2.0);
            double angle;
            for(int i = 1; i <= n-3; ++i){
                angle = (pi/3.0/(n-2))*i;
                double x = cos(angle);
                double y = sqrt(1-x*x);
                printf("%.6lf %.6lf\n",x,y);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值