记忆化搜索 HDU-1078

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9154    Accepted Submission(s): 3844

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.
Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 
Input
There are several test cases. Each test case consists of a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
 
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 
Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 
Sample Output
  
  
37
 
题意:n*n方格有不同数量的食物,老鼠必须每次去往数量更大的点,它每次最多可以移动k个位置,求最多吃到多少。

一开始想的是深搜,把每次吃到的食物量也写进形参里了,然后各种bug。不应该写的那么复杂,形参记录位置,然后答案在函数中直接更新就行了,有点类似数位dp,其实都是记忆话搜索,要多加练习,争取熟练掌握!

#include <iostream>
#include<cstdio>
#include <cstring>

using namespace std;
int ch[101][101], dp[101][101];
int mov1[4] = {1, -1, 0, 0}, mov2[4] = {0, 0, 1, -1};
int maxn, n, k;

int dfs(int x, int y)
{
    int ans = 0;
    if(dp[x][y]) return dp[x][y];
    for(int i = 0; i < 4; i++)
        for(int j = 1; j <= k; j++) // 步长
            if(ch[x][y] < ch[x+j*mov1[i]][y+j*mov2[i]] && x+j*mov1[i] >= 0 && x+j*mov1[i] < n && y+j*mov2[i] >= 0 && y+j*mov2[i] < n) {
                int num = dfs(x + j*mov1[i], y + j*mov2[i]);
                if(ans < num) ans = num;
            }
    return dp[x][y] = ans + ch[x][y];

}

int main()
{
    while(~scanf("%d%d", &n, &k) && (n + k) != -2) {
        maxn = 0;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++) {
                scanf("%d", &ch[i][j]);
                dp[i][j] = 0;
            }
        dfs(0, 0);
        printf("%d\n", dp[0][0]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值