Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.
Your task is counting the segments of different colors you can see at last.
Input
The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.
Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:
x1 x2 c
x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.
All the numbers are in the range [0, 8000], and they are all integers.
Input may contain several data set, process to the end of file.
Output
Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.
If some color can't be seen, you shouldn't print it.
Print a blank line after every dataset.
Sample Input
5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1
Sample Output
1 1
2 1
3 1
1 1
0 2
1 1
题意:给一个区间,有n次染色操作,每次将[x1, x2]染为c,求最后每种颜色各有多少线段可以看到。
#include <bits/stdc++.h>
using namespace std;
int n, last;
int col[8010<<2], ans[8010];
void pushdown(int rt)
{
if(col[rt] != -1) {
col[rt<<1] = col[rt<<1|1] = col[rt];
col[rt] = -1;
return ;
}
}
void update(int L, int R, int l, int r, int rt, int c)
{
if(L<=l && r<=R) {
col[rt] = c;
return ;
}
if(col[rt] == c) return ;
pushdown(rt);
int mid = (l+r)>>1;
if(L <= mid) update(L, R, l, mid, rt<<1, c);
if(mid < R) update(L, R, mid+1, r, rt<<1|1, c);
}
void query(int l, int r, int rt)
{
if(l == r) {
if(col[rt] != -1 && col[rt]!=last) {
ans[col[rt]]++;
}
last = col[rt];
return ;
}
pushdown(rt);
if(l == r) return ;
int mid = (l+r)>>1;
query(l, mid, rt<<1);
query(mid+1, r, rt<<1|1);
}
int main()
{
while(~scanf("%d", &n)) {
memset(col, -1, sizeof(col));
for(int i = 0; i < n; i++) {
int x1, x2, c;
scanf("%d%d%d", &x1, &x2, &c);
update(x1+1, x2, 1, 8000, 1, c);
}
memset(ans, 0, sizeof(ans));
last = -1;
query(1, 8000, 1);
// for(int i = 0; i <= 4; i++) printf("ans[%d] : %d\n", i, ans[i]);
// printf("col[1] = %d\n", col[1]);
for(int i = 0; i <= 8000; i++) if(ans[i]) printf("%d %d\n", i, ans[i]);
puts("");
}
return 0;
}