poj 3789 Milk Patterns(后缀数组+二分答案+height数组分组)

poj 3789 Milk Patterns(后缀数组+二分答案+height数组分组)
Time Limit: 5000ms Memory Limit: 65536kB

Description
Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can’t predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns – 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input
Line 1: Two space-separated integers: N and K
Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

Output
Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4


最近学了后缀数组,虽然思想有点明白了,但是基数排序写得不是很熟,所以只能参考模板了。
后缀数组比较常见的模板有求sa[i]和rank[i]功能和求height[i]功能的代码。其中:
height[i]=length(common_string(suffix(rank[i]),suffix(rank[i-1])));
那么有以下性质,对于suffix(rank[i])与suffix(rank[j])(i< j),有:
length(common_string(suffix(rank[i]),suffix(rank[j])))=min{height[k]} (i< k<=j)
本题思想是利用这一点分组,如果一组之内height都比len大,那么这一组公共子串必定大于len。
所以只需要二分答案转化为一个判定问题即可。


Accepted    820kB   17ms    1474 B  G++ 
#include<stdio.h>

const int ARRAY_SIZE=100010;
const int SMALL_SIZE=2;

typedef int array_type[ARRAY_SIZE];

array_type wa,wb,ws,r,sa,rank,height;

inline int cmp(int* r,int a,int b,int l)
{
    return r[a]==r[b] && r[a+l]==r[b+l];
}

void da(int n,int m)
{
    int i,j,p,*x=wa,*y=wb,*t;
    for (i=0;i<m;i++) ws[i]=0;
    for (i=0;i<n;i++) ws[x[i]=r[i]]++;
    for (i=1;i<m;i++) ws[i]+=ws[i-1];
    for (i=n-1;i>=0;i--) sa[--ws[x[i]]]=i;
    for (p=0,j=1;p<n;j*=2,m=p)
    {
        for (p=0,i=n-j;i<n;i++) y[p++]=i;
        for (i=0;i<n;i++) if (sa[i]>=j) y[p++]=sa[i]-j;
        for (i=0;i<m;i++) ws[i]=0;
        for (i=0;i<n;i++) ws[x[y[i]]]++;
        for (i=1;i<m;i++) ws[i]+=ws[i-1];
        for (i=n-1;i>=0;i--) sa[--ws[x[y[i]]]]=y[i];
        for (t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
            x[sa[i]]=cmp(y,sa[i],sa[i-1],j)?p-1:p++;
    }
    return;
}

void calheight(int n)
{
    int i,j,k=0;
    for (i=1;i<=n;i++) rank[sa[i]]=i;
    for (i=0;i<n;height[rank[i++]]=k)
        for (k?k--:0,j=sa[rank[i]-1];r[j+k]==r[i+k];k++);
    return;
}

bool valid(int len,int n,int k)
{
    int i,t=1;
    for (i=1;i<=n;i++)
        if (height[i]<len)
        {
            if (t>=k)
                return true;
            else
                t=1;
        }
        else
            t++;
    return t>=k;
}

int main()
{
    int n,m=0,k,i,L=0,R,M;
    scanf("%d%d",&n,&k);
    for (i=0;i<n;i++) scanf("%d",&r[i]);
    for (i=0;i<n;i++) if ((++r[i])+1>m) m=r[i]+1;
    r[n]=0;
    da(n+1,m);
    calheight(n);
    R=n+1-k;
    while (R>L+SMALL_SIZE)
    {
        M=(L+R)/2;
        if (valid(M,n,k))
            L=M;
        else
            R=M;
    }
    for (;valid(L,n,k);L++);
    printf("%d\n",L-1);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值