POJ 3259-Wormholes(简单判负环)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

题目大意:给出n个点,m条费用边,k条穿越边。费用边即为走过时需要的时间,穿越边即为走过时可时间返回的一定数值的边。

思路:如此清晰的思路,就是一个简单的判负环问题。但之前一直没有遇到过,算是第一次做负环问题。判负环通常是使用spfa来直接判,但是,能判负环的实质是BF算法,spfa是BF算法加上队列优化的结果,所以有必要去了解一下BF算法。至于spfa的再优化就暂时搁置一下吧。

BF算法:简单来说就是松弛所有的点,遍历所有点,再遍历所有边,进行松弛,因为若有负环存在,那么松弛时就永远松弛不完的,那么利用这一点,进行判环。时间复杂度(VE)

加队列优化:即不断进队出队,从而实现优化,时间复杂度为(KE   k为入队次数)若加上前向星存储方式还能优化,还能优化,详情暂时不知。

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
const int maxn=1010;
const int maxv=5000;
const int INF=1<<29;
struct node{
    int a;
    int b;
    int cost;
}p[maxv];
int d[maxn];
int N,M,W;
int n;
int bf(int s) 
{
    for(int i=1;i<=N;i++) d[i]=INF;
    d[s]=0;
    for(int i=0;i<N;i++) //所有点
    {
        int fag=0;
        for(int j=0;j<n;j++) //所有边
	{
            node p1=p[j];
            if(d[p1.a]!=INF&&d[p1.b]>d[p1.a]+p1.cost) //松弛 
	    {
                d[p1.b]=d[p1.a]+p1.cost;
                fag=1;
                if(i==N-1) return 1;  //松弛次数超过边数即为有负环
            }
        }
        if(!fag) break;
    }
    return 0;
}
int main()
{
    int F,a,b,c;
    scanf("%d",&F);
    while(F--) 
    {
        scanf("%d%d%d",&N,&M,&W);
        n=0;
        for(int i=0;i<M;++i) 
	{  
            scanf("%d%d%d",&a,&b,&c);
            p[n].b=a;p[n].a=b;p[n++].cost=c;
            p[n].b=b;p[n].a=a;p[n++].cost=c;
        }
        for(int i=0;i<W;++i) 
	{  
            scanf("%d%d%d",&a,&b,&c);
            p[n].a=a;p[n].b=b;p[n++].cost=-c;
        }
        int fag=bf(1);
        if(fag==1) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}  

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值