- 找倍数
给定一个正整数 n,请你找到一个它的非零倍数 m。
要求 m 中只包含数字 0 或 1,并且总位数不超过 100 位。
输入格式
输入包含多组测试数据。
每组数据占一行,包含一个正整数 n。
当输入 n=0 时,表示输入结束。
输出格式
每组数据输出一行 m。
如果方案不唯一,则输出任意合理方案均可。
数据范围
1≤n≤200
输入样例:
2
6
19
0
输出样例:
10
100100100100100100
111111111111111111
我们注意到最高位只能为1,所以从1开始搜索,往后面加1或0,加0等价于×10,加1等价于×10+1,所以接下来就很好写了
11 % 2 = ((1 × 10) % 2 + 1) % 2
#include<cstdio>
#include<iostream>
#include<queue>
#pragma GCC optmize(3)
#pragma GCC optmize(2)
using namespace std;
#define INF 0x3f3f3f3f
typedef long long ll;
const int N = 110;
typedef pair<string,ll>pii;
queue<pii>ans;
ll n;
int main(){
while(~scanf("%lld",&n),n){
while(ans.size())ans.pop();
ans.push({"1",1ll});
while(ans.size())
{
auto it=ans.front();
ans.pop();
if(it.second==0){
cout<<it.first<<"\n";
break;
}
ans.push({it.first+"1",(it.second*10+1)%n});
ans.push({it.first+"0",(it.second*10)%n});
}
}
}