逆序建表

数据结构实验之链表二:逆序建立链表
Time Limit: 1000MS Memory limit: 65536K
题目描述
输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。
输入
第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。
输出
依次输出单链表所存放的数据。
示例输入
10
11 3 5 27 9 12 43 16 84 22
示例输出
22 84 16 43 12 9 27 5 3 11
# include  <stdio.h>
# include <stdlib.h>
typedef int Elem ;
typedef struct node{
	Elem data;
	struct node *next;
} Node;
Node *create_linkedlist(int n);
void show(Node *head);
void destroy(Node *head);
int main()
{
	int n;
	scanf("%d",&n);
	Node *head;
	head = create_linkedlist(n);
	show(head);
	destroy(head);
	return 0;
}

Node *create_linkedlist(int n)
{
	Node *head;
	Node *p;
	Elem key;
	head = (Node*)malloc(sizeof(Node));
	head->next = NULL;
	while(n--)
	{
		scanf("%d",&key);
		p = (Node*)malloc(sizeof(Node));
		p->data = key;
		/*逆序就是始终在头结点之后插入,所以新增节点先连上head之后的节点*/
		p->next = head->next;
		/*之后再在头节点后挂上新增节点*/
		head->next = p;
	}
	return head;
}
void show(Node *head)
{
	Node *p;
	p = head->next;
	while(p)
	{
		printf("%d ",p->data);
		p = p->next;
	}
}
void destroy(Node *head)
{
    Node *p;
    Node *q;
    p = head->next;
    while(p)
    {
        q=p;
        /*刚开始我把1 2 颠倒了发现程序死在了销毁上
        问了之后才明白如果2先执行被销毁的结点所含下一个结点的地址就找不到了*/
        p = p->next;//1
        free(q);//2    
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值