树的种类统计

数据结构实验之查找三:树的种类统计
Time Limit: 400ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

输入
输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

输出
按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

示例输入
2
This is an Appletree
this is an appletree
示例输出
this is an appletree 100.00%
<pre name="code" class="cpp"># include <stdio.h>
# include <stdlib.h>
# include <string.h>
typedef struct node
{
    char str[22];//记录树的信息
    struct node*l;
    struct node*r;
    int cnt;//记录树的数量
} Node;
int N;//树的总数
Node*Insert(Node*root,char*s)
{
    if(!root)
    {
        root = (Node*)malloc(sizeof(Node));
        root->cnt = 1;
        strcpy(root->str,s);
        root->l = NULL;
        root->r = NULL;
    }
    else
    {
        int cmp = strcmp(root->str,s);
        if(cmp > 0)
            root->l = Insert(root->l,s);
        else if(cmp < 0)
            root->r = Insert(root->r,s);
        else
            root->cnt++;
    }
    return root;
}
void InOrder(Node*root) //中序遍历
{
    if(root)
    {
        InOrder(root->l);
        printf("%s %.2lf%c\n",root->str,root->cnt*100.0/N,'%');
        InOrder(root->r);
    }
}
int main()
{
    Node*root = NULL;
    char str[22];
    scanf("%d\n",&N); // 必须吃掉输入N之后的换行符!!!!
    getchar();//!!!!!!!!!!!!
    for(int j=0;j<N;j++)
    {
        gets(str);
        for(int i=0;str[i];i++)
        {
            if(str[i] >='A' && str[i] <='Z') //大写转为小写
                str[i] += 32;
        }
        root = Insert(root,str);
    }
    InOrder(root);
    return 0;
}



                
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值