C语言实验——交换两个整数的值(顺序结构)

Problem Description

交换两个变量的值,由终端输入两个整数给变量x、y,然后交换x和y的值后,输出x和y。

Input

从键盘输入两个整数变量x和y;

Output

在交换x、y的值后将x和y输出!

Sample Input

4 6

Sample Output

6 4

代码一:

#include<stdio.h>
#include<stdlib.h>
int main()
{
    int a,b,t;
    scanf("%d %d",&a,&b);
    t=a;a=b;b=t;
    printf("%d %d\n",b,a);
    return 0;
}

代码二:

#include<stdio.h>
#include<stdlib.h>
int main()
{
    int a,b;
    scanf("%d %d",&a,&b);
    a=a+b;
    b=a-b;
    a=a-b;
    printf("%d %d\n",a,b);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值