Problem Description
二叉排序树的定义是:或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值; 若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值; 它的左、右子树也分别为二叉排序树。 今天我们要判断两序列是否为同一二叉排序树
Input
开始一个数n,(1<=n<=20) 表示有n个需要判断,n= 0 的时候输入结束。
接下去一行是一个序列,序列长度小于10,包含(0~9)的数字,没有重复数字,根据这个序列可以构造出一颗二叉排序树。
接下去的n行有n个序列,每个序列格式跟第一个序列一样,请判断这两个序列是否能组成同一颗二叉排序树。(数据保证不会有空树)
Output
Sample Input
2
123456789
987654321
432156789
0
Sample Output
NO
NO
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
int data;
struct node *lc,*rc;
};
struct node *creat(int str,struct node *root)
{
if(root==NULL)
{
root=(struct node*)malloc(sizeof(struct node));
root->data=str;
root->lc = root->rc=NULL;
return root;
}
if(root->data>str)
{
root->lc=creat(str,root->lc);
}
else
{
root->rc=creat(str,root->rc);
}
return root;
};
int k;
void judge(struct node*root1,struct node*root2)
{
if(root1&&root2)//这里用的是if不是while
{
if(root1->data!=root2->data)
{
k=1;
return;
}
judge(root1->lc,root2->lc);//相同则往左递归
judge(root1->rc,root2->rc);//相同则往右递归,调用头函数
}
}
int main()
{
int n,i;
char a[200],b[200];
while(scanf("%d",&n)!=EOF)
{
if(n==0)break;
struct node *root1=NULL;
scanf("%s",a);
for(i=0;a[i]!='\0';i++)
{
root1=creat(a[i],root1);
}
while(n--)
{
struct node *root2=NULL;
k=0;
scanf("%s",b);
for(i=0;b[i]!='\0';i++)
{
root2=creat(b[i],root2);
}
judge(root1,root2);
if(k)printf("NO\n");
else printf("YES\n");
}
}
return 0;
}