1003. Emergency (25)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4
注意求的是the number of different shortest paths;对dijkstra算法要稍作补充,借鉴了下网上的思路,
#include <iostream>
#include <vector>
#include <list>
#include <iterator>
#include <utility>
#define MAX (505)
#define INF (1<<30)
using namespace std;

typedef struct TableEntry
{
    list< pair<int, int> > mylist;
    bool known;
    int dist;
}adjacency_list;

adjacency_list graph[MAX];
int city, road;
int teammax[MAX] = {0};//最大救援队
int counter[MAX] = {0};//最短路径条数计数
vector<int> team;

void graph_init()
{
    int u ,v, w;
    for(int i=0; i<city; i++)
    {
        graph[i].dist = INF;
    }
    for(int i=0; i<road; i++)
    {
        cin >> u >> v >> w;
        graph[u].mylist.push_back(make_pair(v, w));
        graph[v].mylist.push_back(make_pair(u, w));
    }
}

int dijkstra(int start)
{
    int mindist, key;
    list< pair<int, int> >::iterator it;
    graph[start].dist = 0;
    teammax[start] = team[start];
    counter[start] = 1;
    for(int i=0; i<city; i++)
    {
        mindist = INF;
        for(int j=0; j<city; j++)
        {
            if(!graph[j].known && graph[j].dist<mindist)
            {
                mindist = graph[j].dist;
                key = j;
            }
        }
        graph[key].known = true;//找到当前未知的最短路径点key标记已知
        for(it=graph[key].mylist.begin(); it!=graph[key].mylist.end(); it++)//遍历key点的邻接点
        {
            if(!graph[it->first].known)
            {
                if(it->second+mindist < graph[it->first].dist)
                {
                    graph[it->first].dist = it->second+mindist;//如果该邻接点的distance比key点到该点总路径大则更新
                    teammax[it->first] = teammax[key]+team[it->first];//该点救援队数量更新
                    counter[it->first] = counter[key];//最短路径条数更新,即key点最短路径条数
                }
                else if(it->second+mindist == graph[it->first].dist)//相等则说明有多种最短路径情况
                {
                    counter[it->first] += counter[key];//计数,不是+1,前位点可能已经存在多种路径,测试点3
                    if(teammax[it->first] < teammax[key]+team[it->first])//如果该情况下救援队较多则更新最大救援队
                        teammax[it->first] = teammax[key]+team[it->first];
                }
            }
        }
    }
}

int main()
{
    int C1, C2, n;
    cin >> city >> road >> C1 >> C2;
    for(int i=0; i<city; i++)
    {
        cin >> n;
        team.push_back(n);
    }
    graph_init();
    dijkstra(C1);
    cout << counter[C2] << " " << teammax[C2] << endl;
    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值