1044. Shopping in Mars (25)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5

边输入计算现有长度的总价,如果相等则可以直接输出头尾,如果大于所需价格则从头开始截,截止小于或者等于总价,等于就输出,小于继续循环;

#include <iostream>
#include <vector>
#include <cstdio>
#include <utility>
#define MAX 100005
using namespace std;

int main()
{
    int n, total;
    int value = 0;
    int pre = 1;
    vector<int> a(MAX);
    vector< pair<int, int> > mint;//记录不存在相等时的最小项链
    scanf("%d%d", &n, &total);
    int flag = 1;
    int mintotal = MAX;
    for(int i=1; i<=n; i++)
    {
        scanf("%d", &a[i]);
        value += a[i];
        if(value == total)//价格相等则输出
        {
            printf("%d-%d\n", pre, i);
            flag = 0;
        }
        else if(value > total)//价格较大时
        {
            while(value > total)
            {
               if(flag)//如果不存在相等价格时
                {
                    if(value < mintotal)//如果价格比最小的价格还要小则清空之前记录并记录最小价格
                    {
                        mintotal = value;
                        mint.clear();
                        mint.push_back(make_pair(pre, i));
                    }
                    else if(value == mintotal)
                    {
                        mint.push_back(make_pair(pre, i));
                    }
                }
                value -= a[pre];
                pre++;
            }
            if(value == total)//可能正好减至相等就输出
            {
                printf("%d-%d\n", pre, i);
                flag = 0;
            }
        }
    }
    if(flag)
    {
        for(int i=0; i<mint.size(); i++)
            printf("%d-%d\n", mint[i].first, mint[i].second);
    }
    return 0;

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值