浙江大学PAT_甲级_1077. Kuchiguse (20)

题目链接:点击打开链接

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

    Sample Input 1:
    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    
    Sample Output 1:
    nyan~
    
    Sample Input 2:
    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    
    Sample Output 2:
    nai
    求最长公共后缀

    我的C++代码:

    #include<iostream>
    #include<string>
    using namespace std;
    string common_suffix(string a, string b)
    {
    	string common_str= "";//公共后缀
    	int str1_index= a.size() - 1;//字符串a的下标
    	int str2_index= b.size() - 1;//b下标
    
    	while (str1_index >= 0 && str2_index >= 0)//当字符串a/b下标没结束时
    	{
    		if (a[str1_index] == b[str2_index])//从后往前查找相同字符
    		{
    			common_str = a[str1_index] + common_str;//把相同字符添加进common_str
    			str1_index--;//下标向前移动
    			str2_index--;
    		}
    		else 
    			break;//比较完,结束循环
    	}
    	if (common_str == "")
    		common_str = "nai";
    	return common_str;//输出公共后缀
    }
    int main()
    {
    	int i = 0, n = 0;
    	string a, b, common = "";//common公共后缀
    	scanf("%d", &n);//字符串条数
    	cin.get();
    	getline(cin, a);//输入第一个字符串,字符串里有空格时用getline()
    	for (i = 1; i < n; i++)
    	{
    		getline(cin, b);
    		common = common_suffix(a, b);//得到公共字符串
    		a = common;//公共后缀赋值给a,和下一条字符串对比
    	}
    	cout << common;
    	//system("pause");
    	return 0;
    }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值