BGP路由策略

配ip,启用ospf,

10、修改broadcast
[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]ip address 12.0.0.1 24
[R1-GigabitEthernet0/0/0]int g0/0/1
[R1-GigabitEthernet0/0/1]ip address 13.0.0.1 24
[R1-GigabitEthernet0/0/1]int g0/0/2	
[R1-GigabitEthernet0/0/2]ip address 15.0.0.1 24
[R1-GigabitEthernet0/0/2]int l 0
[R1-LoopBack0]ip address 1.1.1.1 32
[R1-LoopBack0]int l 1
[R1-LoopBack1]ip address 192.168.100.1 24
[R1-LoopBack1]ospf network-type b	
[R1-LoopBack1]ospf network-type broadcast 
[R1]ospf 1 router-id 1.1.1.1
[R1-ospf-1]area 0
[R1-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0
[R1-ospf-1-area-0.0.0.0]network 192.168.100.1 0.0.0.0	
[R1-ospf-1-area-0.0.0.0]network 12.0.0.1 0.0.0.0
[R1-ospf-1-area-0.0.0.0]network 13.0.0.1 0.0.0.0
[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip address 12.0.0.2 24
[R2-GigabitEthernet0/0/0]int g0/0/1
[R2-GigabitEthernet0/0/1]ip address 24.0.0.2 24
[R2-GigabitEthernet0/0/1]int l 0
[R2-LoopBack0]ip address 2.2.2.2 32
[R2-LoopBack1]int l 1
[R2-LoopBack1]ip address 192.168.20.1 24	
[R2-LoopBack1]ospf network-type broadcast 
[R2]ospf 1 router-id 2.2.2.2
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0	
[R2-ospf-1-area-0.0.0.0]network 12.0.0.2 0.0.0.0	
[R2-ospf-1-area-0.0.0.0]network 192.168.20.1 0.0.0.0
[R3]int g0/0/0
[R3-GigabitEthernet0/0/0]ip address 34.0.0.3 24
[R3-GigabitEthernet0/0/0]int g0/0/1	
[R3-GigabitEthernet0/0/1]ip address 13.0.0.3 24
[R3-GigabitEthernet0/0/1]int l 0
[R3-LoopBack0]ip address 3.3.3.3 32
[R3-LoopBack0]int l 1
[R3-LoopBack1]ip address 192.168.30.1 32	
[R3-LoopBack1]OSPF network-type broadcast 
[R3]ospf 1 router-id 3.3.3.3
[R3-ospf-1]area 0	
[R3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
[R3-ospf-1-area-0.0.0.0]network 192.168.30.1 0.0.0.0
[R3-ospf-1-area-0.0.0.0]network 13.0.0.3 0.0.0.0
[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]ip address 24.0.0.4 24
[R4-GigabitEthernet0/0/0]int g0/0/1
[R4-GigabitEthernet0/0/1]ip address 34.0.0.4 24
[R4-GigabitEthernet0/0/1]int l 0
[R4-LoopBack0]ip address 4.4.4.4 32
[R4-LoopBack0]int l 1
[R4-LoopBack1]ip address 192.168.2.1 24
[R4-LoopBack1]int l 0
[R4-LoopBack0]ip address 192.168.1.1 24
[R4-LoopBack0]int l 2
[R4-LoopBack2]ip address 192.168.3.1 24
[R5]int g0/0/0	
[R5-GigabitEthernet0/0/0]ip address 15.0.0.5 24
[R5-GigabitEthernet0/0/0]int l 0
[R5-LoopBack0]ip address 192.168.10.1 24
[R5-LoopBack0]int l 1
[R5-LoopBack1]ip address 192.168.11.1 24
[R5-LoopBack1]int l 2	
[R5-LoopBack2]ip address 192.168.12.1 24

BGP

[R1]bgp 123
[R1-bgp]router-id 1.1.1.1
[R1-bgp]peer 15.0.0.5 as-number 500	
[R1-bgp]peer 2.2.2.2 as-number 123	
[R1-bgp]peer 3.3.3.3 as-number 123	
[R1-bgp]peer 2.2.2.2 connect-interface l 0	
[R1-bgp]peer 2.2.2.2 next-hop-invariable
[R1-bgp]peer 2.2.2.2 next-hop-local	
[R1-bgp]peer 3.3.3.3 connect-interface l 0
[R1-bgp]peer 3.3.3.3 next-hop-invariable
[R1-bgp]peer 3.3.3.3 next-hop-local
[R2]bgp 123
[R2-bgp]route-select
[R2-bgp]router-id 2.2.2.2
[R2-bgp]peer 1.1.1.1 as-number 123	
[R2-bgp]peer 1.1.1.1 connect-interface l 0
[R2-bgp]peer 24.0.0.4 as-number 400
[R2-bgp]peer 1.1.1.1 next-hop-invariable
[R2-bgp]peer 1.1.1.1 next-hop-local
[R2-bgp]
[R3]bgp 123
[R3-bgp]router-id 3.3.3.3
[R3-bgp]peer 34.0.0.4 as-number 400	
[R3-bgp]peer 1.1.1.1 as-number 123
[R3-bgp]peer 1.1.1.1 connect-interface l 0	
[R3-bgp]peer 1.1.1.1 next-hop-invariable
[R3-bgp]peer 1.1.1.1 next-hop-local
[R4]bgp 400
[R4-bgp]router-id 4.4.4.4
[R4-bgp]peer 24.0.0.2 as-number 123	
[R4-bgp]peer 34.0.0.3 as-number 123
[R5]bgp 500
[R5-bgp]router-id 5.5.5.5
[R5-bgp]undo peer 1.1.1.1	
[R5-bgp]peer 15.0.0.1 as-number 123
11、BGP宣告路由
[R1]bgp 123
[R1-bgp]network 192.168.20.0 24
[R1-bgp]network 192.168.30.0 24
[R1-bgp]network 192.168.100.0 24
[R2]bgp 123	
[R2-bgp]network 192.168.20.0 24
[R2-bgp]network 192.168.30.0 24
[R2-bgp]network 192.168.100.0 24
[R3]bgp 123
[R3-bgp]network 192.168.20.0 24
[R3-bgp]network 192.168.30.0 24
[R3-bgp]network 192.168.100.0 24
[R4-bgp]network 192.168.1.0 24	
[R4-bgp]network 192.168.2.0 24	
[R4-bgp]network 192.168.3.0 24
[R5-bgp]network 192.168.10.0 24
[R5-bgp]network 192.168.11.0 24	
[R5-bgp]network 192.168.12.0 24
1、
[R4]ip ip-prefix aa permit 192.168.10.0 24
[R4]route-policy aa permit node 10 
[R4-route-policy]if-match ip-prefix aa
[R4-route-policy]apply preferred-value 100
[R4-route-policy]q
[R4]route-policy aa permit node 20
[R4]bgp 400
[R4-bgp]peer 24.0.0.2 route-policy aa import
2、
[R4]ip ip-prefix bb permit 192.168.11.0 24
[R4]route-policy aa permit node 15
Info: New Sequence of this List.
[R4-route-policy]if-match ip-prefix bb
[R4-route-policy]apply as-path 123 123 500 overwrite 
Warning: The AS-Path lists of routes to which this route-policy is applied will 
be overwritten. Continue? [Y/N]y
3、
[R2]ip ip-prefix aa permit 192.168.12.0 24
[R2]route-policy aa permit node 10
Info: New Sequence of this List.
[R2-route-policy]if-match ip-prefix aa
[R2-route-policy]apply cost 200
[R2-route-policy]q
[R2]route-policy aa permit node 20
Info: New Sequence of this List.
[R2-route-policy]q
[R2]bgp 123
[R2-bgp]peer 24.0.0.4 route-p	
[R2-bgp]peer 24.0.0.4 route-policy aa export
[R3]ip ip-prefix aa permit 192.168.12.0 24
[R3]route-policy aa permit node 10
Info: New Sequence of this List.
[R3-route-policy]if-match ip-prefix aa
[R3-route-policy]apply cost 20
[R3-route-policy]q
[R3]route-policy aa permit node 20
Info: New Sequence of this List.
[R3-route-policy]q
[R3]bgp 123	
[R3-bgp]peer 34.0.0.4 route-policy aa export 
4、5、
[R1]ip ip-prefix aa permit 192.168.1.0 24
[R1]ip ip-prefix bb permit 192.168.2.0 24
[R1]route-policy aa permit node 10
Info: New Sequence of this List.
[R1-route-policy]if-match ip-prefix aa
[R1-route-policy]apply local-preference 200
[R1-route-policy]q
[R1]route-policy aa permit node 20
Info: New Sequence of this List.	
[R1-route-policy]q
[R1]route-policy bb permit node 10
Info: New Sequence of this List.
[R1-route-policy]if-match ip-prefix bb
[R1-route-policy]apply local-preference 200
[R1-route-policy]q
[R1]route-policy bb permit node 20
Info: New Sequence of this List.
[R1-route-policy]q
[R1]bgp 123
[R1-bgp]peer 2.2.2.2 route-policy aa import 
[R1-bgp]peer 3.3.3.3 route-policy bb import 
6、
[R1]bgp 123
[R1-bgp]maximum load-balancing 2
7、
[R5]ip as-path-filter 1 deny ^123$
[R5]ip as-path-filter 1 permit .*
[R5]bgp 500
[R5-bgp]peer 15.0.0.1 as-path-filter 1 import
8、(没用自定义)
[R1]ip ip-prefix cc permit 192.168.3.0 24
[R1]route-policy aa permit node 15
Info: New Sequence of this List.
[R1-route-policy]if-match ip-prefix cc
[R1-route-policy]apply community no-export
[R1-route-policy]q	
[R1]route-policy bb permit node 15
Info: New Sequence of this List.
[R1-route-policy]if-match ip-prefix cc
[R1-route-policy]apply community no-export
[R1-route-policy]q

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值