BZOJ 1628: [Usaco2007 Demo]City skyline

Description

The best part of the day for Farmer John's cows is when the sun sets. They can see the skyline of the distant city. Bessie wonders how many buildings the city has. Write a program that assists the cows in calculating the minimum number of buildings in the city, given a profile of its skyline. The city in profile is quite dull architecturally, featuring only box-shaped buildings. The skyline of a city on the horizon is somewhere between 1 and W units wide (1 <= W <= 1,000,000) and described using N (1 <= N <= 50,000) successive x and y coordinates (1 <= x <= W, 0 <= y <= 500,000), defining at what point the skyline changes to a certain height. An example skyline could be: .......................... .....XX.........XXX....... .XXX.XX.......XXXXXXX..... XXXXXXXXXX....XXXXXXXXXXXX and would be encoded as (1,1), (2,2), (5,1), (6,3), (8,1), (11,0), (15,2), (17,3), (20,2), (22,1). 给我们一个由一些矩形构造出来的图,我们需要找到最少矩形的块数来覆盖它 但是这个输入比较奇怪,针对上图,解释如下: 1.1代表在第一列,有高度为1的矩形,矩形由"X"组成.这个矩形有多宽呢,这里并没有告诉你 2.2代表在第二列,有高度为2的矩形,这就间接告诉了你,前面那个矩形有多宽,宽度即2-1 5.1代表在第五列,有高度为1的矩形,这就间接告诉了你,前面那个矩形有多宽,宽度即5-2 This skyline requires a minimum of 6 buildings to form; below is one possible set of six buildings whose could create the skyline above: .......................... .......................... .....22.........333....... .....XX.........XXX....... .111.22.......XX333XX..... .XXX.XX.......5555555..... X111X22XXX....XX333XXXXXXX 4444444444....5555555XXXXX .......................... .....XX.........XXX....... .XXX.XX.......XXXXXXX..... XXXXXXXXXX....666666666666

翻译

        对于农夫约翰的奶牛而言,一天中最好的时光是太阳下山的时候。他们可以看到城市所有高楼在夕阳下的轮廓线。请写一个程序帮助奶牛计算该城市楼房的最低数量的程序。

        输入给出了楼的轮廓线。数据保证所有的“楼”为矩形。轮廓线在地平线的宽度为1~W(1 W≤1000000),给出N(1≤n≤50000)和n个连续的(x,y)坐标(1≤x≤W,0≤y≤500000),以确定在x点处楼高的变化,例如:(1,1), (2,2), (5,1), (6,3), (8,1), (11,0), (15,2), (17,3), (20,2), (22,1)。 其中:(1,1)代表从第1列开始,有高度为1的矩形;(2,2)代表在第2列,有高度为2的矩形,并且也间接告诉了你,前面那个矩形有多宽:从第1列到第2列之前(不包括第2列)宽度即w=2-1=1。(5,1)代表在第5列,有高度为1的矩形,这就间接告诉了你,前面那个矩形有多宽:从第2列到第5列之前(不包括第5列)宽度即w=5-2=3。

Input

* Line 1: Two space separated integers: N and W * Lines 2..N+1: Two space separated integers, the x and y coordinate of a point where the skyline changes. The x coordinates are presented in strictly increasing order, and the first x coordinate will always be 1.
第一行:N与W。 接下来N行,每行一对(x,y)。保证x坐标递增,且第一个x为1.

Output

* Line 1: The minimum number of buildings to create the described skyline.
输出这座城市最少可能拥有的楼数。

Sample Input

10 26
1 1
2 2
5 1
6 3
8 1
11 0
15 2
17 3
20 2
22 1


Sample Output

6

题解

写翻译挺累的。单调栈维护即可,好像高度为0时为地面。

#include<cstdio> 
#include<cstring> 
#include<iostream> 
#include<cstdlib> 
#include<cmath> 
#include<algorithm> 
using namespace std; 
int n,m,h[50002],s[50002],top,ans; 
void init() 
{ 
    scanf("%d%d",&n,&m); 
    int i,x; 
    for(i=1;i<=n;i++) 
       scanf("%d%d",&x,&h[i]); 
} 
void work() 
{ 
    int i; 
    ans=n; 
    for(i=1;i<=n;i++) 
       {while(s[top]>h[i]) top--; 
        if(s[top]==h[i]) ans--; 
        else s[++top]=h[i]; 
       } 
    printf("%d\n",ans); 
} 
int main() 
{ 
    init(); work(); 
    return 0; 
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值