[kuangbin]专题一 简单搜索 N - Find a way

Find a way

  HDU - 2612

Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
 
 
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
 
 
66 88 66


题意:地图上有未知个KFC店,两人需要在KFC店会和,给出两个人的坐标,问两个人最少共花多少时间。

思路:用bfs求出其中一人到所有kfc的最短时间,存在ans[][]里。再用一次bfs求另一个人的,加进ans[][]里。然后遍历ans[][]得到最短时间。

当然也许会有疑惑如果有一个KFC,其中一人能到,另一个人到不了,那可能会得到错的答案。事实上题目说总有一个KFC能让两人都到,那么两人彼此肯定能找到对方,也就是互通。。那么任何一个KFC,只有两种可能两人都能到,或两人都到不了。所以结果没错。

ACcode:

#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
#define INF 0x3f3f3f3f
int sx1,sy1,sx2,sy2,ex,ey;
char map[200][200];
int book[200][200];
int ans[200][200]={0};
int n,m; 
int dx[]={-1,1,0,0};
int dy[]={0,0,-1,1};
struct node{
	int x;
	int y;
	int s;
};
void bfs(int sx,int sy)
{
	node now,next;
	queue<node> q;
	now.x=sx;
	now.y=sy;
	now.s=0;
	book[sx][sy]=1;
	q.push(now);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			next.x=now.x+dx[i];
			next.y=now.y+dy[i];
			if(next.x<0 || next.x>=n || next.y<0 ||next.y>=m)continue;
			if(book[next.x][next.y]==0 && map[next.x][next.y]!='#')
			{
				book[next.x][next.y]=1;
				next.s=now.s+1;
				q.push(next);	
				if(map[next.x][next.y]=='@')	
				ans[next.x][next.y]=ans[next.x][next.y]+(next.s*11);
			}	
		}
	}
	return ;
}
int main()
{
	while(scanf("%d%d",&n,&m)==2)
	{
		for(int i=0;i<n;i++)
			for(int j=0;j<m;j++)
		{
				scanf(" %c",&map[i][j]);
				if(map[i][j]=='Y')
				sx1=i,sy1=j;
				if(map[i][j]=='M')
				sx2=i,sy2=j;	
		}
		memset(book,0,sizeof(book));
		bfs(sx1,sy1);
		memset(book,0,sizeof(book));
		bfs(sx2,sy2);
		int res=INF;
		for(int i=0;i<n;i++)
			for(int j=0;j<m;j++)
			{
				if(ans[i][j]!=0 && ans[i][j]<res)
				res=ans[i][j];
			}
			printf("%d\n",res);
		memset(ans,0,sizeof(ans));
	}
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值