填坑

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/q417190240/article/details/51768268

bug显示
Error:java.lang.UnsupportedClassVersionError: com/android/dx/command/Main : Unsupported major.minor version 52.0
Error: at java.lang.ClassLoader.defineClass1(Native Method)
Error: at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
Error:java.lang.UnsupportedClassVersionError: com/android/dx/command/Main : Unsupported major.minor version 52.0
Error: at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)Error:
……
sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)Error:Exception in thread “main”

当时的环境:

compileSdkVersion 23 
buildToolsVersion “24.0.0” 
minSdkVersion 18
targetSdkVersion 23

我的解决办法:(Android Studio2.1.2)
降低构建版本,在把buildToolsVersion从24.0.0降到23.0.3之后项目就正常了,可以正常运行。
另外提个醒: compile ‘com.android.support:appcompat-v7:24.0.0’需要构建版本达到24才不会报错。可以降低v7包版本,改成23.4.0

展开阅读全文

没有更多推荐了,返回首页