I - Matrix



Time Limit: 3000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

[Submit]   [Go Back]   [Status]

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1
 
  
 
  
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std; 

#define MAXN 1010
int c[MAXN][MAXN];
int n,sum;

int lowbit(int x)
{
	return x&(-x);
}

void updata(int x,int y,int value)
{
	int i,j;
	for(i=x;i<=n;i+=lowbit(i))
		for(j=y;j<=n;j+=lowbit(j))
		{
			c[i][j]+=value;			
		}
}

int query(int x,int y)
{
	int i,j;
	for(i=x;i>0;i-=lowbit(i))
		for(j=y;j>0;j-=lowbit(j))
		{
			sum+=c[i][j];
		}
	return sum;
}

int main()
{
	int t;
	char str[2];
	scanf("%d",&t);
	while(t--)
	{
		memset(c,0,sizeof(c));
		int m;
		scanf("%d%d",&n,&m);
		while(m--)
		{
			scanf("%s",str);
			if(str[0]=='C')
			{
				int x1,y1,x2,y2;
				scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				updata(x1,y1,1);
				updata(x2+1,y2+1,1);
				updata(x1,y2+1,1);
				updata(x2+1,y1,1);
			}
			if(str[0]=='Q')
			{
				int x,y;
				scanf("%d%d",&x,&y);
				sum=0;
				query(x,y);
				printf("%d\n",sum&1);
			}
		}
		printf("\n");
	}
	return 0;
}


好的,下面是修改后的代码,可以用于多站点数据的MK检验: ``` #####设置文件路径###### setwd("D:\山西月降水站点数据\") #####读取所有站点数据###### file_list <- list.files(path = ".", pattern = ".csv") data_list <- list() for (file in file_list) { data <- read.csv(file, colNames = FALSE) data_list[[file]] <- as.matrix(data) } #####MK检验函数###### MK_test <- function(data) { #####对数据求倒序##### data_dx <- rev(data) data_dx <- matrix(data_dx) n <- length(data) #######MK检验####### Q <- matrix(0, 1, n) UF <- matrix(0, 1, n) UB <- matrix(0, 1, n) h <- matrix(0, n, n) for (i in 1:n) { for (j in 1:n) { if (data[i, 1] > data[j, 1]) { h[i, j] <- 1 } else { h[i, j] <- 0 } } Q[1, i] <- sum(h[lower.tri(h)]) UF[1, i] <- (Q[1, i] - (i * (i - 1) / 4)) / sqrt((i * (i - 1) * (2 * i + 5)) / 72) } #####计算UB##### h <- matrix(0, n, n) for (i in 1:n) { for (j in 1:n) { if (data_dx[i, 1] > data_dx[j, 1]) { h[i, j] <- 1 } else { h[i, j] <- 0 } } Q[1, i] <- sum(h[lower.tri(h)]) UB[1, i] <- (Q[1, i] - (i * (i - 1) / 4)) / sqrt((i * (i - 1) * (2 * i + 5)) / 72) } #####输出突变年份##### year_mk <- 1:n year_point <- year_mk[which((as.numeric(UF) - (-rev(UB))) > 0)[1] - 1] return(year_point) } #####对所有站点进行MK检验,并输出突变年份##### for (i in 1:length(data_list)) { data <- data_list[[i]] year_point <- MK_test(data) print(paste(file_list[i], "的突变年份为:", year_point)) } ``` 这段代码的主要修改是使用循环读取所有站点的数据,并对每个站点进行MK检验。具体操作如下: 1. 使用`list.files()`函数读取文件夹中所有以.csv结尾的文件,保存在`file_list`变量中。 2. 使用循环读取每个文件的数据,并保存在`data_list`列表中。 3. 定义`MK_test()`函数,用于对单个站点的数据进行MK检验,具体操作和原代码相同。 4. 使用循环遍历`data_list`列表中的每个站点数据,并调用`MK_test()`函数进行MK检验,输出突变年份。 需要注意的是,每个站点数据的文件名需要包含该站点的名称或标识,以便在输出结果中区分不同站点。另外,该代码仅适用于所有站点数据的格式相同的情况,如果不同站点数据的格式不同,则需要对`MK_test()`函数进行修改以适应不同格式的数据。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值