poj3691 DNA repair

DNA repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5239 Accepted: 2449

Description

Biologists finally invent techniques of repairing DNA that contains segments causing kinds of inherited diseases. For the sake of simplicity, a DNA is represented as a string containing characters 'A', 'G' , 'C' and 'T'. The repairing techniques are simply to change some characters to eliminate all segments causing diseases. For example, we can repair a DNA "AAGCAG" to "AGGCAC" to eliminate the initial causing disease segments "AAG", "AGC" and "CAG" by changing two characters. Note that the repaired DNA can still contain only characters 'A', 'G', 'C' and 'T'.

You are to help the biologists to repair a DNA by changing least number of characters.

Input

The input consists of multiple test cases. Each test case starts with a line containing one integers  N (1 ≤  N ≤ 50), which is the number of DNA segments causing inherited diseases.
The following  N lines gives  N non-empty strings of length not greater than 20 containing only characters in "AGCT", which are the DNA segments causing inherited disease.
The last line of the test case is a non-empty string of length not greater than 1000 containing only characters in "AGCT", which is the DNA to be repaired.

The last test case is followed by a line containing one zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by the
number of characters which need to be changed. If it's impossible to repair the given DNA, print -1.

Sample Input

2
AAA
AAG
AAAG    
2
A
TG
TGAATG
4
A
G
C
T
AGT
0

Sample Output

Case 1: 1
Case 2: 4
Case 3: -1

Source



AC自动机+ dp
首先构造出一个病毒的tire图

我们希望在这个tire图上走出一条长度为n的路径使得不含病毒串
使这个路径与已给的原串 最相似(即改动最小)
考虑dp即可, 如果走的第i个字母与原串的字母不同 ,则花费+1,否则花费不变
最后答案为 min( dp[n][i],  i为所有节点)

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>

using namespace std;

int tree[1010][4];
bool g[1010];
char s[1010];
int f[2][1010][1010];
int p[1010];
int n,ans,tot,m;

queue <int> q;

int  idx(char c)
{
    if (c=='A')  return 0;
    if (c=='T')  return 1;
    if (c=='G')  return 2;
    if (c=='C')  return 3;
}

int main()
{
    int cas=0;
    while (1)
    {
        tot=0;
        memset(g,0,sizeof(g));
        memset(p,0,sizeof(p));
        memset(tree,0,sizeof(tree));
        scanf("%d",&m);
        if (m==0)  break;
        tot=0;
        for (int i=1; i<=m; i++)
        {
            scanf("%s",s);
            int len=strlen(s),u=0;
            for (int j=0; j<len; j++)
            {
                char c=s[j];
                if ( !tree[u][idx(c)] )
                    tree[u][idx(c)]=++tot;
                u=tree[u][idx(c)];
            }
            g[u]=1;
        }
        queue <int> q;
        for (int i=0; i<4; i++)
            if (tree[0][i])
                q.push(tree[0][i]);
        while (!q.empty())
        {
            int r=q.front();
            q.pop();
            for (int i=0; i<4; i++)
            {
                int u=p[r];
                while (  u && !tree[u][i] )  u=p[u];

                int v= tree[r][i];
                if ( v )
                {
                    q.push( v );
                    p[ v ] = tree[u][i];
                    g[ v ] |=  g[ p[v] ];
                }
                else
                    tree[r][i]= tree[u][i];
            }
        }
        scanf("%s",s);
        memset(f,-1,sizeof(f));
        n=strlen(s);
        f[0][0][0]=0;
        for (int i=0; i<n; i++)
            for (int j=0; j<=tot; j++)
                if (f[0][i][j]>=0)
                    for (int k=0; k<4; k++)
                    {
                        if (f[  g[tree[j][k]] ][ i+1] [ tree[j][k] ] == -1)
                            f[  g[tree[j][k]] ][ i+1] [ tree[j][k] ] =   f[0][i][j] +  (k==idx(s[i]) ? 0 : 1)  ;
                        else
                            f[  g[tree[j][k]] ][ i+1] [ tree[j][k] ] =  min( f[  g[tree[j][k]] ][ i+1] [ tree[j][k] ], f[0][i][j] +  ( k==idx(s[i]) ? 0 : 1)  ) ;

                    }
        ans=100000;
        for (int i=0; i<=tot; i++ )
            if (f[0][n][i]>=0)
                ans=min( f[0][n][i],ans);
        if (ans==100000) ans=-1;
        printf("Case %d: %d\n",++cas,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值