UVa 10054 - The Necklace 欧拉回路

7 篇文章 0 订阅

Problem D: The Necklace 

My little sister had a beautiful necklace made of colorful beads. Two successive beads in the necklace shared a common color at their meeting point. The figure below shows a segment of the necklace:

But, alas! One day, the necklace was torn and the beads were all scattered over the floor. My sister did her best to recollect all the beads from the floor, but she is not sure whether she was able to collect all of them. Now, she has come to me for help. She wants to know whether it is possible to make a necklace using all the beads she has in the same way her original necklace was made and if so in which order the bids must be put.

Please help me write a program to solve the problem.

Input 

The input contains T test cases. The first line of the input contains the integer T.

The first line of each test case contains an integer N ( $5 \leN \le 1000$) giving the number of beads my sister was able to collect. Each of the next N lines contains two integers describing the colors of a bead. Colors are represented by integers ranging from 1 to 50.

Output 

For each test case in the input first output the test case number as shown in the sample output. Then if you apprehend that some beads may be lost just print the sentence ``some beads may be lost" on a line by itself. Otherwise, print N lines with a single bead description on each line. Each bead description consists of two integers giving the colors of its two ends. For $1 \le i \le N ­ 1$, the second integer on line i must be the same as the first integer on line i + 1. Additionally, the second integer on line Nmust be equal to the first integer on line 1. Since there are many solutions, any one of them is acceptable.

Print a blank line between two successive test cases.

Sample Input 

2
5
1 2
2 3
3 4
4 5
5 6
5
2 1
2 2
3 4
3 1
2 4

Sample Output 

Case #1
some beads may be lost
 
Case #2
2 1
1 3
3 4
4 2
2 2



Miguel Revilla 
2000-12-28


一道经典的欧拉回路问题
1.满足节点的度都是偶数,
2.在打印欧拉路径的时候,因为在输入中可能出现重复的情况,所以在每输出一个时,需要在图g 中对应的位置减去一。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int MAX = 50+1;

int g[MAX][MAX], in[MAX], out[MAX];
int vis[MAX][MAX];
int first=0;

void read()
{
	int n;
	cin>>n;
	int u, v;
	for(int i=1; i <= n; i++)
	{
		cin >> u >> v;
		in[v]++;
		out[u]++;
		g[u][v]++;
		g[v][u]++;
		if(!first) first = u;
	}
}

void dfs(int u)
{
	for(int v=1; v <= 50; v++)
	{
		if(g[u][v] && !vis[u][v])
		{
			vis[u][v] = 1;
			dfs(v);
		}
	}
}
// 是否具有连通性质 
bool isCycle()
{
	int count=0;
	for(int i=1; i <= 50; i++)
	{
		for(int j=1; j <= 50; j++)
		{
			if(g[i][j])
			{
				if(!vis[i][j])
				{
					count++;
					dfs(i);
				}
			}
		}
	}
	if(count > 1)
		return false;
	return true;
}

bool isEuler()
{
	// 对度数是否为偶数的判断 
	for(int i=1; i <= 50; i++)
	{
		if((in[i]+out[i])%2)
			return false;
	}
	return true;
}
// 打印欧拉回路 
void output(int u)
{
	for(int v=1; v <= 50; v++)
	{
		//if(g[u][v] && !vis[v][u])
		// 无向图并且可能会出现重复的情况 vis不需要 
		if(g[u][v])
		{
	//		vis[u][v]=  vis[v][u] = 1;
			--g[u][v];
			--g[v][u];
			output(v);
			cout << v << " " << u << endl;

		}
	}
}


void init()
{
	memset(g, 0, sizeof(g));
	memset(in, 0, sizeof(in));
	memset(out,0, sizeof(out));
	memset(vis, 0, sizeof(vis));
}

int main()
{
//	freopen("in.txt","r",stdin);
	int nCase;
	cin >> nCase;
	for(int i=1; i <= nCase; i++)
	{
		init();
		read();
		cout << "Case #" << i << endl;
		if(isCycle())
		{
			if(isEuler()){
				for(int i=1; i <= 50; i++)
					output(i);
			}
			else
				cout << "some beads may be lost" << endl;
		}else
			cout << "some beads may be lost" << endl;
		cout << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值