HUD 1002 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 261740    Accepted Submission(s): 50656


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

思路 大数加法高精度


#include<stdio.h>

int main()
{
    int n,i,d,n1,n2,p;
    char a[1100], b[1100],c[1100],x;
    scanf("%d",&n);
    getchar();
    for(i=1;i<=n;i++)
    {
        d=0;p=0;
        while((x=getchar())!=' ')
        {
            a[d]=x;
            d++;
        }
        n1=d-1;
        d=0;
        while((x=getchar())!='\n')
        {
            b[d]=x;
            d++;
        }
        n2=d-1;
        printf("Case %d:\n",i);
        for(d=0;d<=n1;d++)
        {
            printf("%c",a[d]);
        }
        printf(" + ");
        for(d=0;d<=n2;d++)
        {
            printf("%c",b[d]);
        }
        printf(" = ");
        for(d=0;n1>=0||n2>=0;n1--,n2--,d++)
        {
            if(n1>=0&&n2>=0)
            {
                c[d]=a[n1]+b[n2]-'0'+p;
            }
            if(n1>=0&&n2<0)
            {
                c[d]=a[n1]+p;
            }
            if(n2>=0&&n1<0)
            {
                c[d]=b[n2]+p;
            }
            p=0;
            if(c[d]>'9')
            {
                c[d]=c[d]-10;
                p=1;
            }
        }

        if(p==1)
        {
            printf("1");
        }
        while(d--)
        {
            printf("%c",c[d]);
        }
        if(i==n)
        {
            printf("\n");
        }
        else
        printf("\n\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值