POJ 1328 Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 64759 Accepted: 14555

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


题目大意:有一条无限长的海岸线,边上有N个小岛,你要在海岸线上安装雷达,每个雷达可以扫描半径为d的范围,问你 最少安装多少个雷达使得所有小岛都可以扫描到

思路:贪心,每个小岛记录一下当雷达装在什么范围之内可以扫描到这个小岛,然后贪心让雷达建立的位置尽量靠右


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
#define inf 100000
#define maxn 1005

struct lsland
{
    int x,y;
    double l,r;
}p[maxn];

bool cmp(lsland a,lsland b)
{
    return a.l < b.l;
}

void fun(lsland &a,double d)
{
    double l = sqrt(d*d - double(a.y*a.y));
    a.l = a.x - l,a.r = a.x + l;
}

int main()
{
    int n,Case = 1,d;
    while(~scanf("%d%d",&n,&d), n||d){
        bool x = 0;
        for(int i = 0; i < n; i++){
            scanf("%d%d",&p[i].x,&p[i].y);
            if(p[i].y > d) x = true;
        }
        if(x) {
            printf("Case %d: -1\n",Case++);
            continue;
        }
        for(int i = 0; i < n; i++) fun(p[i],d);
        sort(p,p+n,cmp);
        int cut = 1;
        double flag = p[0].r;
        for(int i = 1; i < n; i++){
            if(flag < p[i].l) {cut++;flag = p[i].r;}
            else if(flag > p[i].r) flag = p[i].r;
        }
        printf("Case %d: %d\n",Case++,cut);
    }
    return 0;
}
/*
3 2
1 2
-3 1
2 1

1 2
0 2

3 1
1 2
-3 2
2 3

3 0
1 2
-3 1
2 1

0 0
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值