POJ 1068 Parencodings

2 篇文章 0 订阅
Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23163 Accepted: 13574

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9



题目大意

 给你一个数组P,pi 等于 第i个右括号前面有多少个左括号

要你求出对应的W数组,wi 等于 第i个右括号与其对应的左括号中有多少个左括号


思路: 模拟,之后根据模拟所得,计算并且输出对应的W数组


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
#define inf 0xffffff
#define maxn 22

int dis[maxn],ans[maxn],vis[maxn*2],n;
//dis储存输入数据,ans储存输出数据,vis储存模拟


void fun()
{
    int flag = 0,top = 0;
    
    //进行模拟
    for(int i = 0; i < n; i++){
        for(int j = flag;j < dis[i]; j++) {vis[top++] = -1;}
        flag = dis[i];
        vis[top++] = 1;
    }
    
    /*****************************
    for(int i = 0; i < top; i++)
        cout<<(vis[i]>0? ')':'(');
    cout<<endl;
    *****************************/
    
    flag = 0;
    for(int i = 0; i < top; i++){
        if(vis[i] == 1){
            int dix = 1,j = i - 1,x = 1;
            while(x){
                x += vis[j--];
                dix++;
            }
            ans[flag++] = dix/2;
        }
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        cin>>n;
        for(int i = 0; i < n; i++) cin>>dis[i];
        fun();
        //这里是个坑,要比平时多打一个空格
        for(int i = 0; i < n; i++) cout<<ans[i]<<' ';
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值