1097. Deduplication on a Linked List (25)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

题目大意:

就是给你一个链表,让你把其中绝对数相同的元素去重,然后把去重后的链表和被去除的节点组成的链表输出

思路:

我感觉稍微需要注意的一点就是需要一个book数组,来记录那些节点已经有了,还有就是输出的时候可以用printf("%05d",a); 把数字格式控制一下,别的都是很简单的链表操作。

代码:

#include<iostream>
#include<vector>
using namespace std;
struct Node {
    int ad;
    int data;
    int next;
};
Node node[100010];
int book[10010];
int main() {
    int first,n,i,j;
    vector<Node> ans1,ans2;
    scanf("%d%d",&first,&n);
    for(i=0;i<n;i++) {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        node[a].ad=a;
        node[a].data=b;
        node[a].next=c;
    }
    int t=first;
    while(t!=-1) {
        int temp=(node[t].data<0?-node[t].data:node[t].data);
        if(book[temp]==0) {
            ans1.push_back(node[t]);
            book[temp]=1
        } 
        else {
            ans2.push_back(node[t]);
        }
        t=node[t].next;
    }
    for(i=0;i<ans1.size();i++) {
        if(i!=ans1.size()-1)
            printf("%05d %d %05d\n",ans1[i].ad,ans1[i].data,ans1[i+1].ad);
        else 
            printf("%05d %d -1\n",ans1[i].ad,ans1[i].data);
    }
    for(i=0;i<ans2.size();i++) {
        if(i!=ans2.size()-1)
            printf("%05d %d %05d\n",ans2[i].ad,ans2[i].data,ans2[i+1].ad);
        else 
            printf("%05d %d -1\n",ans2[i].ad,ans2[i].data);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值