找出最大矩形面积(枚举)

找出最大
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%lld & %llu

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑  0<=j<=i-1wj <= x <= ∑  0<=j<=iwj} 
Again, define set S = {A| A = WH for some W , H ∈ R  + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 
Your mission now. What is Max(S)? 
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 
But for this one, believe me, it's difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w  11+w  22+...+w  nn < 10  9.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14
给出每小块矩形的长
枚举直接过
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
	int a[100000],b[100000];
	int n;
	while(scanf("%d",&n)&&n!=-1)
	{int sum=0,ans=0,k=0,l=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&a[i],&b[i]);
		}
		for(int i=1;i<=n;i++)//枚举每个小矩形
		{
			sum=a[i];
			for(int j=i+1;j<=n;j++)
			{
				if(b[j]>=b[i])
				sum+=a[j];
				else
				break;//向右搜索
			}
				for(int k=i-1;k>=1;k--)
			{
				if(b[k]>=b[i])//向左搜索
				sum+=a[k];
				else
				break;
			}
			ans=max(ans,sum*b[i]);//找出最大
			
		}
		printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值