HDOJ 5615 Jam's math problem (数学题枚举)

Jam's math problem
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Jam has a math problem. He just learned factorization. 
He is trying to factorize   into the form of 
He could only solve the problem in which p,q,m,k are positive numbers. 
Please help him determine whether the expression could be factorized with p,q,m,k being postive.
 

Input

The first line is a number  , means there are   cases 

Each case has one line,the line has   numbers 
 

Output

You should output the "YES" or "NO".
 

Sample Input

      
      
2 1 6 5 1 6 4
 

Sample Output

      
      
YES NO

Hint

 The first case turn $x^2+6*x+5$ into $(x+1)(x+5)$ 
         

枚举求解:

#include<stdio.h>
int main()  
{  
    int t;  
    __int64 a,b,c,i,j;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%I64d%I64d%I64d",&a,&b,&c);  
        int k=0;  
        for(i=1;i*i<=a;i++)  
        {  
            if(a%i)  //枚举p,q
            continue;  
            for(j=1;j*j<=c;j++)  
            {  
                if(c%j)  //枚举k,m
                continue;  
                if(i*j+(a/i)*(c/j)==b||i*(c/j)+j*(a/i)==b) //<span style="white-space:pre">	</span>判断是否是方程的解 
                {  
                    k=1;  
                    break;  
                }  
            }  
            if(k)  
            break;  
        }  
        if(k)  
	        printf("YES\n");  
	        else  
	        printf("NO\n");  
	    }  
	    return 0;  
	}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值