POJ 2503 Babelfish(人造字典map)

                                                         Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 40424 Accepted: 17216

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

   
   
dog ogday
cat atcay
froot ootfray
pig igpay
atcay
loops oopslay
ittenkay
oopslay

Sample Output

   
   
cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

你刚刚从滑铁卢搬到一个大城市。这里的人们讲一门外语的一个难以理解的方言。幸运的是,你有一个字典帮助你了解他们。

输入包含字典条目多达100000,紧随其后的是一个空行,紧随其后的是一个消息的100000字。每一个字典条目包含一个英语单词是一条直线,紧随其后的是一个空间和一门外语单词。没有外国单词不止一次出现在字典里

用map对应键值,但因为不会对应字符串类键值,所以较麻烦

#include<stdio.h>
#include<map>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
char h[100001][20];
int main()
{char a[20],b[20],c[20];
int k=1;
int p=0;
map<string,int>l;//定义容器
for(int i=0;;i++)
{
for(int i=0;;i++)
{
	scanf("%c",&a[i]);
	if(a[i]==' ')
	{
		a[i]='\0';
		break;
	}
	if(a[i]=='\n')
	{
		p=1;
		break;
	}
}
if(p==1)
break;
scanf("%s",b);
getchar();
   l[b]=k;
   strcpy(h[k++],a);

  
}
while(~scanf("%s",c))	
{if(l[c]==0)
printf("eh\n");
else
printf("%s\n",h[l[c]]);
}
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值