POJ1985 Cow Marathon 树的直径

                                     Cow Marathon
Time Limit:2000MS Memory Limit:30000KB 64bit IO Format:%lld & %llu
Submit

Status
Description
After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms.
Input
* Lines 1.....: Same input format as "Navigation Nightmare".
Output
* Line 1: An integer giving the distance between the farthest pair of farms.
Sample Input
7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
Sample Output
52
Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52.

字母并没什么用,直接查找树的直径

1.随便找一个点进行第一遍bfs,可以保证最远的点一定是树的直径的一个端点,
2.以第一遍bfs找到的树的直径的端点为起点,进行第二遍bfs,找到另一个端点,它们之间的距离就是树的直径。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
#define M 310000
struct node {
	int v,next,w;
}mp[M*3];
int cnt,head[M],dis[M],vis[M];
int ans,last;
void add(int u,int v,int w){
	mp[cnt].v=v;
	mp[cnt].w=w;
	mp[cnt].next=head[u];
	head[u]=cnt++;
}
void bfs(int s){
	queue<int> q;
	memset(vis,0,sizeof(vis));
	memset(dis,0,sizeof(dis));
	vis[s]=1;
	last=s;
	ans=0;
	q.push(s);
	while(!q.empty()){
		int u=q.front();
		q.pop();
		for(int i=head[u];i!=-1;i=mp[i].next){
			int v=mp[i].v;
			if(!vis[v] && dis[v]<dis[u]+mp[i].w){
				vis[v]=1;
				dis[v]=dis[u]+mp[i].w;
				if(ans<dis[v]){
					ans=dis[v];
					last=v;
				}
				q.push(v);
			}
		}
	}
}
int main(){
	int t,n,m,a,b,c,k=1;
	char ch;
	while(~scanf("%d%d",&n,&m)){
		
		cnt=0;
		memset(head,-1,sizeof(head));
		for(int i=0;i<n-1;i++){
			scanf("%d %d %d %c",&a,&b,&c,&ch);
			add(a,b,c);
			add(b,a,c);
		}
		bfs(1);
		bfs(last);

		printf("%d\n",ans); 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值