Seaside最短路,找到最近靠海地)

Seaside
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.

Input

There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S  Mi and L  Mi, which means that the distance between the i-th town and the S  Mi town is L  Mi.

Output

Each case takes one line, print the shortest length that XiaoY reach seaside.

Sample Input

5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1

Sample Output

2
题目输入解释:
数据输入第一个是N,然后是N组数据,第i组数据第一个是 Mi和Pi, Mi代表城市i有多少条边,P代表是否与海边相邻,然后接下来是MI组数据 每组 两个数 第一个表示城市编号L, i和这个城市相连,后面的数是DIS,代表L和i的权值。
#include<stdio.h>  
#include<string.h>   
int dis[20][20],vis[20],t;  
void floyd(){  
int i,j,k;  
for(k=0;k<t;k++)  
 for(i=0;i<t;i++)  
for(j=0;j<t;j++)  
if(dis[i][j]>dis[i][k]+dis[k][j])  
 dis[i][j]=dis[i][k]+dis[k][j];  
}    
int main(){  
    while(scanf("%d",&t)!=EOF){  
    for(int i=0;i<20;i++)  
    for(int j=0;j<20;j++)  
    if(i==j)  
    dis[i][j]=0;
    else
    dis[i][j]=100000000;
for(int i=0;i<t;i++){  
int m,p;  
scanf("%d%d",&m,&vis[i]);   
while(m--){  
int a,cost;  
scanf("%d%d",&a,&cost);  
if(dis[i][a]>cost)  
dis[i][a]=dis[a][i]=cost;  
}  
}  
floyd();  
int ans=1000000000;  
for(int i=0;i<t;i++)  
if(vis[i])  
if(ans>dis[0][i])  
ans=dis[0][i];  
printf("%d\n",ans);  
}  
return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值