LightOJ - 1079 Just another Robbery 概率 + dp

                              Just another Robbery
Time Limit:4000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probabilityP of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

Hint

For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That's why he has only option, just to rob rank 2.

题目大意:了解到每个银行有多少钱,和去抢劫该银行被捕的概率 ,拟定一个计划,要求在被捕概率低于p的情况下,抢劫到最多的钱;

题解:

将其转化为背包问题,被捕概率等于1-不被捕概率dp[i]表示抢劫i元不被捕概率;

找出1-dp[i]<=p时i的最大值,即为所求

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
double dp[11000],p,a[110];
int n,b[110];
int main()
{              int k=1,t;
	scanf("%d",&t);
	while(t--)
	{int sum=0;
	memset(dp,0,sizeof(dp));
	dp[0]=1.0;
	  scanf("%lf%d",&p,&n);
	  for(int i=1;i<=n;i++)
	  {
	   scanf("%d%lf",&b[i],&a[i]);
	   sum+=b[i];
	   a[i]=1.0-a[i];
                 }
                 for(int i=1;i<=n;i++)
                 for(int j=sum;j>=b[i];j--)
                 {   
                    dp[j] = max(dp[j], dp[j-b[i]]*a[i]);
	  }
	  for(int i=sum;i>=0;i--)
	  {
	  	if(p>=1-dp[i])
	  	{
	  	printf("Case %d: %d\n",k++,i);
	  	break;
		  }
	  }
	  
               }
	
	
	
	
 } 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值