【大数阶乘】HDU 1042 N! C++高精度模板

HDU 1042    N!                                                                                

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 89844    Accepted Submission(s): 26564

题目链接->点击打开链接


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input
One N in one line, process to the end of file.  

Output
For each N, output N! in one line.
 
Sample Input
 
 
1 2 3
 

Sample Output
 
 
1 2 6
 

Author
JGShining(极光炫影)
 
Recommend
We have carefully selected several similar problems for you:   1002  1715  1047  1063  1753 

Problem Idea

 【类型】
  C++ 大数阶乘 高精度模板题
 【注意】

  10000的阶乘,乘积4000位不够用,要40000位够用

 

   AC  Code

#include <iostream>
#include<cstring>
using namespace std;
const int nmax=40000;//10000的阶乘需要40000位 
int d[nmax];//存放阶乘的各位
 
int main(int argc, char** argv) {
	int n;
	int i,j;
	while(cin>>n){
		memset(d,0,sizeof(d));
		d[0]=1;
		int t=0;
		for(i=1;i<=n;i++){//1到n相乘,计算阶乘 
			int carry=0;
			for(j=0;j<=t;j++){
				int tmp=d[j]*i+carry;
				d[j]=tmp%10;
				carry=tmp/10;
			}
			while(carry!=0){
				d[++t]=carry%10;
				carry=carry/10;
			}
		}
		
		for(int i=t;i>=0;i--){
			printf("%d",d[i]);
		}printf("\n"); 
	} 
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值