Boy or Girl

 题目:

# Boy or Girl

## 题面翻译

那些日子,许多男孩在论坛上使用漂亮女孩的照片作为化身。所以很难在第一眼就知道用户的性别。去年,我们的英雄去了一个论坛,和一位美女聊天(他想是这样)。之后,他们经常交谈,最终他们成为了网络中的一对情侣。

但是昨天,他在现实世界里看到了“她”,发现“她”其实是一个非常强壮的男人!我们的英雄很伤心,他太累了,不能再爱了。因此,他想出了一种通过用户名来识别用户性别的方法。

这是他的方法:如果用户名中的不同字符数是奇数,那么他是男性,否则她是女性。您给出了表示用户名的字符串,请用我们的方法帮助我们的英雄确定这个用户的性别。

如果是女生,输出 `CHAT WITH HER!`;如果是男生,则输出`IGNORE HIM!`。

翻译提供者:友利奈绪

## 题目描述

Those days, many boys use beautiful girls' photos as avatars in forums. So it is pretty hard to tell the gender of a user at the first glance. Last year, our hero went to a forum and had a nice chat with a beauty (he thought so). After that they talked very often and eventually they became a couple in the network.

But yesterday, he came to see "her" in the real world and found out "she" is actually a very strong man! Our hero is very sad and he is too tired to love again now. So he came up with a way to recognize users' genders by their user names.

This is his method: if the number of distinct characters in one's user name is odd, then he is a male, otherwise she is a female. You are given the string that denotes the user name, please help our hero to determine the gender of this user by his method.

## 输入格式

The first line contains a non-empty string, that contains only lowercase English letters — the user name. This string contains at most 100 letters.

## 输出格式

If it is a female by our hero's method, print "CHAT WITH HER!" (without the quotes), otherwise, print "IGNORE HIM!" (without the quotes).

## 样例 #1

### 样例输入 #1

```
wjmzbmr
```

### 样例输出 #1

```
CHAT WITH HER!
```

## 样例 #2

### 样例输入 #2

```
xiaodao
```

### 样例输出 #2

```
IGNORE HIM!
```

## 样例 #3

### 样例输入 #3

```
sevenkplus
```

### 样例输出 #3

```
CHAT WITH HER!
```

## 提示

For the first example. There are 6 distinct characters in "wjmzbmr". These characters are: "w", "j", "m", "z", "b", "r". So wjmzbmr is a female and you should print "CHAT WITH HER!".

嘤嘤嘤好真实因为我也被骗过当然我也骗过别人

这题我们可以先排列,再看看有没有相邻两个相同

这里我们可以用

s.erase(unique(s.begin(), s.end()), s.end());

来进行去重,字符串/数组都能用

核心代码:
void solve(){
    // 竞赛程序
    cin >> s;
	sort(s.begin(), s.end());//记得要先排序
	s.erase(unique(s.begin(), s.end()), s.end());
	puts(s.size() & 1 ? "IGNORE HIM!" : "CHAT WITH HER!");
}
完整代码AC code:
#include <iostream>		// 基本入出力ストリーム
#include <algorithm>	// 一般的なアルゴリズム(ソート、ルックアップ、やり直し、二分ルックアップなど)
#include <vector>		// 動的配列(スペースが足りないと自動的に拡張されます)
#include <queue>		//  スタック(先に入って先に出ます)
#include <stack>		// スタック(先に入ってから出ます)
#include <set>			// 集合(反復しない順序)です
#include <map>			// キー値対コンテナ(マッピング)
#include <list>			//  両方向リスト
#include <math.h>		//  すうがくかんすう
#include <functional>	// 通用的函数绑定和调用机制一般的なバインディングと呼び出しの仕組み

#define endl '\n'
#define pii pair<int, int>
#define pdd pair<double, double>
#define fi first
#define se second
#define pb push_back
#define eb emplace_back

using namespace std;

const int inf = 1e9 + 7;
const int mod = 998244353;
const int N = 2e5 + 10, M = N << 1;
string s;
void solve(){
    // 竞赛程序
    cin >> s;
	sort(s.begin(), s.end());//记得要先排序
	s.erase(unique(s.begin(), s.end()), s.end());
	puts(s.size() & 1 ? "IGNORE HIM!" : "CHAT WITH HER!");
}

signed main(){

    ios::sync_with_stdio(0);
    cin.tie(0); cout.tie(0);

    int t = 1;
//	cin >> t;	// 非多组测试数据请注释该行
    while(t--) solve();
    return 0;
}

 记得给点赞呀!

  • 27
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
Girl类的定义如下: ``` #include <iostream> #include <string> using namespace std; class Boy; //前置声明Boy类 class Girl { private: string name; int age; public: Girl(string n, int a) : name(n), age(a) {} ~Girl() {} void Print() { cout << "Girl's name: " << name << endl; cout << "Girl's age: " << age << endl; } void VisitBoy(Boy& b); //声明Boy类的友元成员函数 friend void visitBoyGirl(Boy&, Girl&); //声明友元函数 }; void Girl::VisitBoy(Boy& b) { cout << "Girl's name: " << name << endl; cout << "Girl's age: " << age << endl; cout << "Boy's name: " << b.name << endl; cout << "Boy's age: " << b.age << endl; } class Boy { private: string name; int age; public: Boy(string n, int a) : name(n), age(a) {} ~Boy() {} void Print() { cout << "Boy's name: " << name << endl; cout << "Boy's age: " << age << endl; } friend void Girl::VisitBoy(Boy& b); //声明Girl类的友元成员函数 friend void visitBoyGirl(Boy&, Girl&); //声明友元函数 }; void visitBoyGirl(Boy& b, Girl& g) { cout << "Girl's name: " << g.name << endl; cout << "Girl's age: " << g.age << endl; cout << "Boy's name: " << b.name << endl; cout << "Boy's age: " << b.age << endl; } int main() { Girl girl("ZHOU Yuxing", 16); Boy boy("Chen Qi", 15); girl.Print(); boy.Print(); girl.VisitBoy(boy); //调用Girl类的友元成员函数 visitBoyGirl(boy, girl); //调用友元函数 return 0; } ``` 运行结果: ``` Girl's name: ZHOU Yuxing Girl's age: 16 Boy's name: Chen Qi Boy's age: 15 Boy's name: Chen Qi Boy's age: 15 Girl's name: ZHOU Yuxing Girl's age: 16 Boy's name: Chen Qi Boy's age: 15 ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Digital_Enigma

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值