微软2016校园招聘4月在线笔试:Font Size

Font Size

时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

描述

Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven's phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)  

So here's the question, if Steven wants to control the number of pages no more than P, what's the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

输入

Input may contain multiple test cases.

The first line is an integer TASKS, representing the number of test cases.

For each test case, the first line contains four integers N, P, W and H, as described above.

The second line contains N integers a1, a2, ... aN, indicating the number of characters in each paragraph.


For all test cases,

1 <= N <= 103,

1 <= W, H, ai <= 103,

1 <= P <= 106,

There is always a way to control the number of pages no more than P.

输出

For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

样例输入
2
1 10 4 3
10
2 10 4 3
10 10
样例输出
3
2
//#include "stdafx.h"
#include<iostream>
#include<cstring>
#include<string>
#include<math.h>
#include<algorithm>
#include<stdlib.h>
using namespace std;


int main()
{
// freopen("in.txt", "r", stdin);
int t;
cin >> t;
int N, P, W, H;

while (t--){
cin >> N >> P >> W >> H;
int sum = 0;
int *a = new int[N];
for (int i = 0; i < N; i++){
cin >> a[i];
sum += a[i];
}
int m = min(W, H);
int sum_l=0;
for (int i = m; i >= 1; i--){
for (int j = 0;j < N;j++){
sum_l += a[j] % (W / i);
}
sum_l = sum + sum_l;

if (((W / i)*(H / i)*P) >= sum_l){
cout << i << endl;
sum_l = 0;
break;
}
sum_l = 0;
}
}

//freopen("CON", "r", stdin);
//system("pause");
return 0;
}

 
   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值