优先队列(UVAL-3135)

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: �Every five minutes, retrieve the maximum temperature over the past five minutes.� Query-2: �Return the average temperature measured on each floor over the past 10 minutes.�

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_num Period

Q_num (0 < Q_num ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input 

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of �#�.

The second part is your task. This part contains only one line, which is one positive integer K (≤ 10000).

Output 

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input 

Register 2004 200
Register 2005 300
#
5

Sample Output 

2004
2005
2004
2004
2005
 
 
题目的大概意思是这样的,
Rigister num period
每period就产生一个num事件.
让你求出前k个时间的编号。经典的优先队列维护。

贴出代码:
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <string>
#include <queue>

using namespace std;

struct node
{
	int num;
	int period;
	int time;
	
	bool operator < (const node& t) const
	{
		if (time != t.time)
		{
			return time > t.time;
		}
		else
		{
			return num > t.num;
		}
	}
}t;

priority_queue <node> Q;

void init()
{
	while (!Q.empty())
	{
		Q.pop();
	}
}

int main()
{
	char str[22];
	init();
	while (scanf("%s", str) == 1)
	{
		if (str[0] == '#')
		{
			break;
		}
		scanf("%d%d", &t.num, &t.period);
		t.time = t.period;
		Q.push(t);
	}
	int k;
	scanf("%d", &k);
	for (int i = 0; i < k; i++)
	{
		t = Q.top();
		Q.pop();
		printf("%d\n", t.num);
		t.time += t.period;
		Q.push(t);
	}	
//	system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值