Argus
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 10984 | Accepted: 5272 |
Description
A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.
We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.
For the Argus, we use the following instruction to register a query:
Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.
Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes."
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."
We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.
For the Argus, we use the following instruction to register a query:
Register Q_num Period
Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.
Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.
Input
The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#".
The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).
The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).
Output
You should output the Q_num of the first K queries to return the results, one number per line.
Sample Input
Register 2004 200
Register 2005 300
#
5
Sample Output
2004
2005
2004
2004
2005
题意:有若干任务,给出任务的id(各个任务唯一)和执行间隔时间(每个任务不唯一);要求按照执行时间来输出前k个任务的id号; 当两个任务在同一个时间执行时,先输出id小的。
题解:
1堆排序:
很明显可以建立一个小顶堆,以执行时间最靠前的任务放在堆顶,执行完之后,加上间隔时间,重新调堆。
第一次手写堆排序,一顿抄模板,蔡茹苟。。。
代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[100];
int k;
struct node
{
int num,per,now;
}a[3010];
void down(int s,int m)
{
node rec=a[s];
int j;
for(j=s*2;j<=m;j*=2)
{
if(j<m)
{
if(a[j].now>a[j+1].now)
j++;
else{
if((a[j].now==a[j+1].now)&&(a[j].num>a[j+1].num))
j++;
}
}
if(rec.now<a[j].now||(rec.now==a[j].now&&rec.num<a[j].num))
break;
a[s]=a[j];
s=j;
}
a[s]=rec;
}
void MakeMinHeap(int len)//建一个最小堆
{
for(int i=len/2;i>0;--i)
down(i,len);
}
int main()
{
int i=1;
while(scanf("%s",str)&&(str[0]!='#'))
{
scanf("%d%d",&a[i].num,&a[i].per);
a[i].now=a[i].per;
i++;
}
scanf("%d",&k);
int len=i-1;
MakeMinHeap(len);
while(k--)
{
printf("%d\n",a[1].num);
a[1].now+=a[1].per;
down(1,len);
}
return 0;
}
2优先队列:
用优先队列就很方便了,不过数据结构这东西还是经常手写写比较好
代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define maxn 1010
using namespace std;
char str[100];
struct node
{
int num,per,cnt;
}a,temp;
bool operator < (const node &x, const node &y)
{
if(x.per==y.per)
return x.num>y.num;
else
return x.per>y.per;
}
int main()
{
int k,i;
priority_queue<node>q;
while(scanf("%s",str)&&str[0]!='#')
{
scanf("%d%d",&a.num,&a.per);
a.cnt=a.per;
q.push(a);
}
scanf("%d",&k);
while(k--)
{
temp=q.top();
q.pop();
printf("%d\n",temp.num);
temp.per+=temp.cnt;
q.push(temp);
}
return 0;
}