简单的动态规划 Max Sum

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input

    
    
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6 

这个题很简单,但是!!自己开始做的时候不知道咋想的对起点的处理处理错了。。。其实很好想,如果前面那个dp[i-1]大于0,那么i的起点和i-1起点相同,否则i的起点就是自己所在位置,代码如下:
#include <stdio.h>
#include <stdlib.h>

int main()
{
    int t,n,i,ans,num[100000],dp[100000],st,end,cas,blankline;
    blankline=cas=0;
    int s[100000];
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(i=0;i<n;i++){
            scanf("%d",&num[i]);
        }
        ans=dp[0]=num[0];
        st=end=0;
        s[0]=0;
        for(i=1;i<n;i++){
            if(dp[i-1]<0){
                dp[i]=num[i];
                s[i]=i;
            }else{
                dp[i]=dp[i-1]+num[i];
                s[i]=s[i-1];
            }
        }
        for(i=1;i<n;i++){
            if(dp[i]>ans){
                ans=dp[i];
                st=s[i];
                end=i;
            }
        }
        if(blankline)
            printf("\n");
        printf("Case %d:\n",++cas);
        printf("%d %d %d\n",ans,st+1,end+1);
        blankline++;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值