BUY LOW, BUY LOWER

Description

The advice to "buy low" is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems' advice:
                    "Buy low; buy lower"

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices.

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy.

Here is a list of stock prices:
 Day   1  2  3  4  5  6  7  8  9 10 11 12 
Price 68 69 54 64 68 64 70 67 78 62 98 87


The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is:
Day    2  5  6 10 
Price 69 68 64 62

Input

* Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given

* Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers.

Output

Two integers on a single line:
* The length of the longest sequence of decreasing prices
* The number of sequences that have this length (guaranteed to fit in 31 bits)

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they "look the same" when the successive prices are compared. Thus, two different sequence of "buy" days could produce the same string of decreasing prices and be counted as only a single solution.

Sample Input

12
68 69 54 64 68 64 70 67 78 62
98 87

Sample Output

4 2

很明显这是一个求最长下降子序列并且要求记录子序列个数的问题。求最长下降子序列很好求,关键是记录子序列个数不重复,设f[i]代表子序列结尾为price[i]且长度为dp[i]的子序列个数(i之前的,不包括i之后),那么长度为l的子序列个数总可以转移到在i之前长度为i-1且最后一个数大于price[i]的子序列个数之和,其中要注意,如果两个dp[m],dp[n]相等且price[m],price[n]相等,那么如果m比n大,f[m]已经包含了f[n],所以我们这里用一个mark[]来标记哪个price已经被加过了,避免重复加。代码如下:


#include<stdio.h>
#include<string.h>
int dp[5001],price[5001],f[5001],mark[70000];
/*f[i]代表以price[i]结尾的长度为dp[i]的方案数*/
int max(int a,int b){
    return a>b?a:b;
}
int main(){
    int N,ans1,ans2,i,j;
    scanf("%d",&N);
    for(i=0;i<N;i++)
        scanf("%d",&price[i]);
    ans1=1;
    for(i=0;i<N;i++){
        dp[i]=1;
        for(j=0;j<i;j++){
            if(price[j]>price[i])
                dp[i]=max(dp[i],dp[j]+1);
        }
        ans1=max(dp[i],ans1);
    }

    for(i=0;i<N;i++){
        if(dp[i]==1){
            f[i]=1;
            continue;
        }
        for(j=i-1;j>=0;j--){
            if(dp[j]+1==dp[i]&&price[j]>price[i]&&!mark[price[j]]){
                mark[price[j]]=1;
                f[i]+=f[j];
            }
        }
        memset(mark,0,sizeof(mark));
    }
    ans2=0;
    for(i=N-1;i>=0;i--){
        if(ans1==dp[i]&&!mark[price[i]]){
            mark[price[i]]=1;
            ans2+=f[i];
        }
    }
    printf("%d %d\n",ans1,ans2);
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值