hdoj1002A + B Problem II(大数加法)~

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
【题目大意】:输入A,B,算出这两个数的和。
输入:第一行输入一个整数T,代表有T组测试数据,然后后面跟T行,每行有两个整数A,B,并且这两个整数很大。
输出:对于每组测试数据,输出两行,第一行输出"Case #",#表示第几组测试数据,第二行输出一个等式"A + B = Sum"(注意等式里的空格,当时做的时候就被坑了),每两组测试数据之间有一个空行。
【解题思路】:这是一道大数加法题,由于数字足够大,所以要先将数字用字符串输入然后一位一位地进行运算。
【注意】:这道题有一定的输出格式,写的时候要注意格式。
 
AC代码:
#include<stdio.h>
#include<string.h>
#define MAX_LEN 1000
int an1[MAX_LEN+20];
int an2[MAX_LEN+20];
char szline1[MAX_LEN+20];
char szline2[MAX_LEN+20];
int main()
{
	int t;
	scanf("%d",&t);
for(int s=1;s<=t;s++)
{

	scanf("%s",szline1);//用字符串形式输入两个很大的数
	scanf("%s",szline2);
	int i,j;
	memset(an1,0,sizeof(an1));//数组清零
	memset(an2,0,sizeof(an2));
	int nlen1=strlen(szline1);//求字符串1的长度
	for(j=0,i=nlen1-1;i>=0;i--)
	   an1[j++]=szline1[i]-'0';//将字符串数组中每一个字符转化为数字,并将数字倒置,即个位在前
	int nlen2=strlen(szline2);
	for(j=0,i=nlen2-1;i>=0;i--)
	   an2[j++]=szline2[i]-'0';
	for(i=0;i<MAX_LEN;i++)
	{
		an1[i]+=an2[i];//对应位上的数字相加
		if(an1[i]>=10)//如果需要进位
		{
			an1[i]-=10;//当前位上减去10
			an1[i+1]++;//它的高一位上进1
		}
	}
	printf("Case %d:\n%s + %s = ",s,szline1,szline2); //注意输出格式
	for(i=MAX_LEN;(i>=0)&&(an1[i]==0);i--);//跳过高位的0
	if(i>=0)
	  for(;i>=0;i--)
	    printf("%d",an1[i]);
	else printf("0");
	if(s==t)
	printf("\n");
	else if(s<t)
	printf("\n\n");
}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值