搜索-Q

  • 原题

    Description
    A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

    Note: the number of first circle should always be 1.

    Input
    n (0 < n < 20).

    Output
    The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

    You are to write a program that completes above process.

    Print a blank line after each case.

    Sample Input
    6
    8

    Sample Output
    Case 1:
    1 4 3 2 5 6
    1 6 5 2 3 4

    Case 2:
    1 2 3 8 5 6 7 4
    1 2 5 8 3 4 7 6
    1 4 7 6 5 8 3 2
    1 6 7 4 3 8 5 2

  • 思路&解析
    题意:环是组合成n个圆圈所示的图。把自然数1,2,…,n为进分别各圈,和数字中的两个相邻圈之和应该是一个素数。
    注意:第一圈的数量始终应为1。
    输出格式如下图所示的样品。每一行代表一个系列的圆形数字的环从1开始顺时针和按逆时针方向。号的顺序,必须满足上述要求。在字典顺序打印解决方案。
    请你写一个程序,完成上述过程。
    打印每个案例后,一个空行。

  • AC代码

#include<bits/stdc++.h>
using namespace std;
 int prime[38]=
 {
     0, 0, 1, 1, 0, 1, 0,
     1, 0, 0, 0, 1, 0, 1,
     0, 0, 0, 1, 0, 1, 0,
     0, 0, 1, 0, 0, 0, 0,
     0, 1, 0, 1, 0, 0, 0,
     0, 0, 1,
 };
 void Output(int a[], int n)
 {
    for(int i=0;i<n;i++)
    {
      if(i==n-1)
      cout<<a[i];
      else
      cout<<a[i]<<" ";
    }
     cout<<endl ;
 }
 bool IsOk(int a[], int lastIndex, int curValue)
 {
     if(lastIndex<0)
         return true ;
     if(!((curValue+a[lastIndex]) & 1))
         return false ;
     if(!prime[a[lastIndex]+curValue])
         return false ;
     for(int i = 0; i <= lastIndex; i++)
        if(a[i] == curValue)
         return false ;
     return true ;
 }
 void PrimeCircle(int a[], int n, int t)
 {
     if(n & 1)
        return;
    if(t==n)
     {
         if(prime[a[0]+a[n-1]])
             Output(a,n);
     }
     else
     {
         for(int i=2;i<=n;i++)
         {
             a[t]=i;
             if(IsOk(a,t-1,i))
             PrimeCircle(a,n,t+1);
         }
     }
 }
 int main()
 {
     int a[20],n,k=1;
     while(scanf("%d",&n)!=EOF)
     {
         cout<<"Case "<<k<<":"<<endl;
         k++;
         a[0]=1;
         PrimeCircle(a,n,1);
         printf("\n");
     }
     return 0 ;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值