二分水题

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 
Input
The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output
For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 
Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output
61.329
225.020
0.000

题意:给出一个一条直线长度随温度变化的式子,说现在有这样一条直线在两面墙中间,长度l,受到温度n,随温度变化的常量是c,求直线中点在温度变化下上升高度x。

题解:这是一道二分加数学知识的题目。二分的原因是,我们显然知道x增大,弧长增大,由于存在这样的关系,所以可以二分。然后如何判断假设的值是否正确,则需要点数学知识,先是,通过勾股定理求出半径,然后再求半径和中垂线的夹角,再由弧长=半径*夹角可得弧长,在和事先求得的弧长比较,就可判断是否取得。

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <sstream>
#include <fstream>
#include <set>
#include <map>
#define INF 1e9
#define EPS 1e-6
#define M_PI 3.14159265358979323846
using namespace std;
typedef pair<int,int> P;
typedef long long ll;
double l,n,c,L;
bool can(double x)
{
    double R = (x*x+(l/2)*(l/2))/(2*x);//由假设答案求半径
    double ang = asin((l/2)/R);//求半径和中垂线的夹角
    double u = ang*R;//求弧长
    if(u <= L/2)
        return true;
    else
        return false;
}
int main()
{
    while (scanf("%lf",&l)!=EOF)
    {
        scanf("%lf %lf",&n,&c);
        if(l==-1&&n==-1&&c==-1)
            break;
        if(!n)//如果n==0,直接返回0,不然半径无穷大不能计算
        {
            printf("%.3f\n",0.0);
            continue;
        }
        L = (1 + n*c)*l;
        double lb = 0,ub = l/2;//最小答案是0,最大答案是l/2
        while (ub-lb>EPS)
        {
            double mid = (ub+lb)/2;
            if(can(mid))
            {
                lb = mid;
            }
            else
                ub = mid;
        }
        printf("%.3f\n",lb);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值