POJ 2096 Collecting Bugs(概率DP求期望)

47 篇文章 0 订阅
23 篇文章 0 订阅

传送门

Collecting Bugs
Time Limit: 10000MS
Memory Limit: 64000K
Total Submissions: 4333
Accepted: 2151
Case Time Limit: 2000MS
Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

Northeastern Europe 2004, Northern Subregion

题目大意:

这个题目大意是真的难懂呀...还是英语太渣了呀。。。

就是说一个软件有 s 个subcomponents,  n 个bug,n种分类。那么给你 n 和 s,一个人呢每次只能发现一个bug,而且这个bug属于一个subcomponents,也属于一个分类, 那么每个bug属于subcomponents的概率都是相等的也就是 1/s,属于分类的概率也是相等的 就是 1/n,让你求的是每一个subcomponents都发现 一种bug(一共是n种)的期望次数


解题思路:
这是一个比较简单的概率DP求期望的问题,设DP[i][j]表示的是:已经找到 i 种bug,并且属于 j 个subcomponents

那么它肯定有4种状态,下次发现的Bug:

可能不增加,即DP[i][j],概率是i/n * j/s

可能只增加bug种类,即DP[i+1][j],概率是(n-i)/n * j/s

可能只增加subcomponents即DP[i][j+1],概率是i/n * (s-j)/s

可能既然增加bug种类,又增加subcomponents即DP[i+1][j+1],概率是(n-i)/n * (s-j)/s

所以:

dp[i][j]=(i*(s-j)*dp[i][j+1]+(n-i)*j*dp[i+1][j]+(n-i)*(s-j)*dp[i+1][j+1]+n*s)/(n*s-i*j),保留4位小数

My Code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN = 1e3+5;
double dp[MAXN][MAXN];
///dp[i][j]:已经有i种bug,存在j种子系统中的期望
int main()
{
    int s, n;///s种子系统,n种bug
    while(cin>>n>>s)
    {
        memset(dp, 0, sizeof(dp));
        for(int i=n; i>=0; i--)
        {
            for(int j=s; j>=0; j--)
            {
                if(i==n && j==s)
                    continue;
                double p0 = (1.0*i/n) * (1.0*j/s);
                double p1 = (1.0*(n-i)/n) * (1.0*j/s);
                double p2 = (1.0*i/n) * (1.0*(s-j)/s);
                double p3 = (1.0*(n-i)/n) * (1.0*(s-j)/s);
                dp[i][j] = (p1*dp[i+1][j]+p2*dp[i][j+1]+ p3*dp[i+1][j+1]+1)/(1-p0);
            }
        }
        printf("%.4lf\n",dp[0][0]);
    }
    return 0;
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值