Problem Description
编写程序,输入一个分数,将其约分为最简分式。
Input Description
在一行中输入一个分数。
Output Description
在一行中输出约分后的最简分式。
Sample Input
6/12
Sample Output
1/2
#include <stdio.h>
int main() {
int a,b,c,d,t;
scanf("%d/%d",&a,&b);
c=a,d=b;
while (b!=0&&d!=0)
{
t=c%d;
c=d;
d=t;
}
printf("%d/%d\n",(a/c),(b/c));
return 0;
}