hdu 3486 Interviewe


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4469    Accepted Submission(s): 1095


Problem Description
YaoYao has a company and he wants to employ m people recently. Since his company is so famous, there are n people coming for the interview. However, YaoYao is so busy that he has no time to interview them by himself. So he decides to select exact m interviewers for this task.
YaoYao decides to make the interview as follows. First he queues the interviewees according to their coming order. Then he cuts the queue into m segments. The length of each segment is , which means he ignores the rest interviewees (poor guys because they comes late). Then, each segment is assigned to an interviewer and the interviewer chooses the best one from them as the employee.
YaoYao’s idea seems to be wonderful, but he meets another problem. He values the ability of the ith arrived interviewee as a number from 0 to 1000. Of course, the better one is, the higher ability value one has. He wants his employees good enough, so the sum of the ability values of his employees must exceed his target k (exceed means strictly large than). On the other hand, he wants to employ as less people as possible because of the high salary nowadays. Could you help him to find the smallest m? 
Input
The input consists of multiple cases.
In the first line of each case, there are two numbers n and k, indicating the number of the original people and the sum of the ability values of employees YaoYao wants to hire (n≤200000, k≤1000000000). In the second line, there are n numbers v1, v2, …, vn (each number is between 0 and 1000), indicating the ability value of each arrived interviewee respectively.
The input ends up with two negative numbers, which should not be processed as a case. 
Output
For each test case, print only one number indicating the smallest m you can find. If you can’t find any, output -1 instead.
Sample Input
11 300
7 100 7 101 100 100 9 100 100 110 110
-1 -1 
Sample Output
3
Hint
We need 3 interviewers to help YaoYao. The first one interviews people from 1 to 3, the second interviews people from 4 to 6, 
and the third interviews people from 7 to 9. And the people left will be ignored. And the total value you can get is 100+101+100=301>300. 
Source

2010 ACM-ICPC Multi-University Training Contest(5)——Host by BJTU 

Rmq+二分
#include<stdio.h>
#define N 200010
#define inf 0x3fffffff
#include<string.h>
int a[N],d[N][30],n;
int max(int a,int b)
{
	return a>b?a:b;
}
void rmq_init(int a[N])
{
	int i,j;
	memset(d,0,sizeof(d));
	for(i=0;i<n;i++)
		d[i][0]=a[i];
	for(j=1;(1<<j)<=n;j++)
		for(i=0;i+(1<<j)-1<n;i++)
			d[i][j]=max(d[i][j-1],d[i+(1<<(j-1))][j-1]);
}
int rmq(int l,int r)
{
	int k=0;
	while((1<<(k+1))<=r-l+1)   k++;
	return max(d[l][k],d[r-(1<<k)+1][k]);
}
int main()
{
	int b,k,j,i,ans,r,l,min,m,max,num,sum;
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		if(n<0||k<0)
			break;
		num=0;  max=-1;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			if(a[i]>max)
				max=a[i];
			num+=a[i];
		}
		if(max>k)
		{
			printf("1\n");  continue;
		}
		if(num<=k)
		{
			printf("-1\n");  continue;
		}
		rmq_init(a);
	    l=1;r=n; 
		while(l<=r)
		{
			m=(l+r)>>1;
			sum=0;   b=n/m;
		    for(j=1;j<=m;j++)
			{
				sum+=rmq((j-1)*b,j*b-1);
				if(sum>k)
					break;
			}
			/*for(j=0;j+b-1<n;j+=b)
			{
				sum+=rmq(j,j+b-1);
				if(sum>k)
					break;
			}*///为什么这样写就错了,晕死,不知怎么回事,先放着。。。
			if(sum>k)
			{
			  min=m;
			  r=m-1;
			}
			else
			  l=m+1;
		}
	   printf("%d\n",min);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值